summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-07-16 10:35:57 -0700
committerShadowKyogre2016-07-16 10:35:57 -0700
commit605814ef30f94fd2c13ef4f31a8312965e2bdd35 (patch)
tree18cd75b36bcd8c7d03abc47d8de693f217e67c53
parenta1631e099a5af89c862055a6dc3033087a4e91c0 (diff)
downloadaur-605814ef30f94fd2c13ef4f31a8312965e2bdd35.tar.gz
Force compile in C++98 mode
Otherwise, it won't build.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad3fa069c43f..c306c63af875 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Dec 12 18:12:33 UTC 2015
+# Sat Jul 16 17:35:32 UTC 2016
pkgbase = magicseteditor
pkgdesc = A program to help create Magic: the Gathering cards and sets. Comes with no game support.
pkgver = 2.0.0
- pkgrel = 12
+ pkgrel = 13
url = http://magicseteditor.sourceforge.net
install = magicseteditor.install
arch = i686
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 289d47647e50..71a0816d2a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Sapphira Armageddos <shadowkyogre.public+aur@gmail.com>
pkgname=magicseteditor
pkgver=2.0.0
-pkgrel=12
+pkgrel=13
pkgdesc="A program to help create Magic: the Gathering cards and sets. Comes with no game support."
arch=('i686' 'x86_64')
url="http://magicseteditor.sourceforge.net"
@@ -20,7 +20,7 @@ build() {
./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config-2.8
#sed -e 's|^\(AM_LDFLAGS = .*\),--as-needed|\1,-Bsymbolic-functions|' -i Makefile
make LIBS="-lboost_system $(pkg-config --libs hunspell) $(wx-config-2.8 --libs)" \
- CPPFLAGS="-I/usr/include/hunspell -fpermissive" || return 1
+ CPPFLAGS="-std=c++98 -I/usr/include/hunspell -fpermissive" || return 1
}