summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorepitron2016-08-19 13:10:07 -0400
committerepitron2016-08-19 13:10:07 -0400
commit224a6d3e99245842bf385ec1c5b9768ad4fcd150 (patch)
tree8caf0ca440dacdbf9b0ec579374007081279336a
parent924b4a1533fda479b334ac9e3097388a11ab3a56 (diff)
downloadaur-224a6d3e99245842bf385ec1c5b9768ad4fcd150.tar.gz
Update to 2.0.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa2ede5958a1..38ee179eab7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Aug 19 17:09:59 UTC 2016
pkgbase = magma-atlas
- pkgdesc = A dense linear algebra library, similar to LAPACK, for doing caluclations on GPUs and GPUs simultaneously (built against CUDA and atlas-lapack)
- pkgver = 1.7.0
+ pkgdesc = A dense linear algebra library, similar to LAPACK, for doing caluclations on GPUs and CPUs simultaneously (built against CUDA and atlas-lapack)
+ pkgver = 2.0.2
pkgrel = 1
url = http://icl.cs.utk.edu/magma/
arch = i686
@@ -15,8 +17,8 @@ pkgbase = magma-atlas
provides = magma
conflicts = magma
options = staticlibs
- source = http://icl.cs.utk.edu/projectsfiles/magma/downloads/magma-1.7.0-b.tar.gz
- sha1sums = 8f0ad5e981f2bf57c2e012f90993d4b8a5cd5eac
+ source = http://icl.cs.utk.edu/projectsfiles/magma/downloads/magma-2.0.2.tar.gz
+ sha256sums = 930e0420692695f9bbdb7b89af93f0969e1adc3888df89f26800ba6bc3347f70
pkgname = magma-atlas
diff --git a/PKGBUILD b/PKGBUILD
index 834bf88a4a5c..9a425c547912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,14 @@
# Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com>
##### Configuration Options
-# Specify GPU compute capability Tesla (1.x) or Fermi (2.x) or Kepler (3.x)
-#_GPU_TARGET=Tesla
-#_GPU_TARGET=Fermi
-_GPU_TARGET=Kepler
+# Set to latest CUDA target
+_GPU_TARGET=sm50
##### End
pkgname=magma-atlas
-pkgver=1.7.0
+pkgver=2.0.2
pkgrel=1
-pkgdesc="A dense linear algebra library, similar to LAPACK, for doing caluclations on GPUs and GPUs simultaneously (built against CUDA and atlas-lapack)"
+pkgdesc="A dense linear algebra library, similar to LAPACK, for doing caluclations on GPUs and CPUs simultaneously (built against CUDA and atlas-lapack)"
arch=("i686" "x86_64")
url="http://icl.cs.utk.edu/magma/"
provides=(magma)
@@ -20,8 +18,8 @@ conflicts=('magma')
license=(custom)
depends=("cuda>=5.5.0" "gcc-libs-multilib" "gsl" "python" "cblas" "atlas-lapack")
options=('staticlibs')
-sha1sums=('8f0ad5e981f2bf57c2e012f90993d4b8a5cd5eac')
-source=("http://icl.cs.utk.edu/projectsfiles/magma/downloads/magma-${pkgver}-b.tar.gz")
+sha256sums=('930e0420692695f9bbdb7b89af93f0969e1adc3888df89f26800ba6bc3347f70')
+source=("http://icl.cs.utk.edu/projectsfiles/magma/downloads/magma-${pkgver}.tar.gz")
build() {
cd ${srcdir}/magma-${pkgver}