summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Vondruš2019-10-26 13:17:13 +0200
committerVladimír Vondruš2019-10-26 13:17:13 +0200
commit4f73fac21152ceb6075044fab5b74c61d66d185a (patch)
tree23182888414e067e211d137b833d79a52b2490ad
downloadaur-4f73fac21152ceb6075044fab5b74c61d66d185a.tar.gz
Initial commit of version 2019.10.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a5c7f4c8ac2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = magnum-bindings-git
+ pkgdesc = Bindings for the Magnum C++11/C++14 graphics engine (Git version)
+ pkgver = 2019.10.r0.g396e48b
+ pkgrel = 1
+ url = https://magnum.graphics
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = pybind11
+ depends = magnum-git
+ depends = python
+ provides = magnum-bindings
+ conflicts = magnum-bindings
+ source = git+git://github.com/mosra/magnum-bindings.git
+ sha1sums = SKIP
+
+pkgname = magnum-bindings-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9101427520b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Author: mosra <mosra@centrum.cz>
+pkgname=magnum-bindings-git
+pkgver=2019.10.r0.g396e48b
+pkgrel=1
+pkgdesc="Bindings for the Magnum C++11/C++14 graphics engine (Git version)"
+arch=('i686' 'x86_64')
+url="https://magnum.graphics"
+license=('MIT')
+depends=('magnum-git' 'python')
+makedepends=('cmake' 'git' 'pybind11')
+provides=('magnum-bindings')
+conflicts=('magnum-bindings')
+source=("git+git://github.com/mosra/magnum-bindings.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//g'
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake "$srcdir/${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_PYTHON=ON
+ make
+}
+
+package() {
+ # Helper headers
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
+
+ # Native and python packages
+ cd "$srcdir/build/src/python"
+ python setup.py install --root="$pkgdir" --prefix=/usr
+}