summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Vondruš2015-06-27 20:07:06 +0200
committerVladimír Vondruš2015-06-27 20:07:06 +0200
commita0e5d2adeae4ffee5e83b41011504b4ce67f5815 (patch)
tree5ab2e613895fd278fc693f3a1944d990e6208437
downloadaur-a0e5d2adeae4ffee5e83b41011504b4ce67f5815.tar.gz
Initial package import.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a528e7801e26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = magnum-examples-git
+ pkgdesc = Examples for Magnum OpenGL graphics engine (Git version)
+ pkgver = snapshot.2015.05.r30.gb27164a
+ pkgrel = 1
+ url = http://mosra.cz/blog/magnum.php
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = magnum-git
+ depends = magnum-plugins-git
+ depends = magnum-integration-git
+ depends = bullet
+ provides = magnum-examples
+ conflicts = magnum-examples
+ source = git+git://github.com/mosra/magnum-examples.git
+ sha1sums = SKIP
+
+pkgname = magnum-examples-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3141b78bf054
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Author: mosra <mosra@centrum.cz>
+pkgname=magnum-examples-git
+pkgver=snapshot.2015.05.r30.gb27164a
+pkgrel=1
+pkgdesc="Examples for Magnum OpenGL graphics engine (Git version)"
+arch=('i686' 'x86_64')
+url="http://mosra.cz/blog/magnum.php"
+license=('MIT')
+depends=('magnum-git' 'magnum-plugins-git' 'magnum-integration-git' 'bullet')
+makedepends=('cmake' 'git')
+provides=('magnum-examples')
+conflicts=('magnum-examples')
+source=("git+git://github.com/mosra/magnum-examples.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake "$srcdir/${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_BULLET=ON \
+ -DWITH_CUBEMAP=ON \
+ -DWITH_MOTIONBLUR=ON \
+ -DWITH_PRIMITIVES=ON \
+ -DWITH_PICKING=ON \
+ -DWITH_TEXT=ON \
+ -DWITH_TEXTUREDTRIANGLE=ON \
+ -DWITH_TRIANGLE=ON \
+ -DWITH_VIEWER=ON
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
+}