summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Vondruš2022-07-06 14:31:44 +0200
committerVladimír Vondruš2022-07-06 14:31:44 +0200
commit5f73ee1f585030655786bd10fa9b3a845eb1318f (patch)
treee7acce35cee82b112c9ab4a638ee422fa56d4ae1
parent9d9204c71c5a8cb7f01e496d91f92f19474a7e2d (diff)
downloadaur-magnum-integration-git.tar.gz
Switch away from git://, use prefixed CMake options.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d002a4fe07d7..fe673beacbb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = magnum-integration-git
pkgdesc = Integration libraries for the Magnum C++11/C++14 graphics engine (Git version)
- pkgver = 2020.06.r40.ga157a78
+ pkgver = 2020.06.r145.g012d62b
pkgrel = 1
url = https://magnum.graphics
arch = i686
@@ -15,10 +15,9 @@ pkgbase = magnum-integration-git
depends = glm
provides = magnum-integration
conflicts = magnum-integration
- source = git+git://github.com/mosra/magnum-integration.git
+ source = git+https://github.com/mosra/magnum-integration.git
source = https://github.com/ocornut/imgui/archive/v1.76.tar.gz
sha1sums = SKIP
sha1sums = 6d5d7688197e8002d916da8ddee81bfdd471176d
pkgname = magnum-integration-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f7f072efbab..5bc8515f5f46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Author: mosra <mosra@centrum.cz>
pkgname=magnum-integration-git
-pkgver=2020.06.r40.ga157a78
+pkgver=2020.06.r145.g012d62b
_imgui_pkgver=1.76
pkgrel=1
pkgdesc="Integration libraries for the Magnum C++11/C++14 graphics engine (Git version)"
@@ -11,7 +11,7 @@ depends=('magnum-git' 'bullet' 'eigen' 'glm')
makedepends=('cmake' 'git' 'ninja')
provides=('magnum-integration')
conflicts=('magnum-integration')
-source=("git+git://github.com/mosra/magnum-integration.git"
+source=("git+https://github.com/mosra/magnum-integration.git"
"https://github.com/ocornut/imgui/archive/v${_imgui_pkgver}.tar.gz")
sha1sums=('SKIP'
'6d5d7688197e8002d916da8ddee81bfdd471176d')
@@ -31,11 +31,11 @@ build() {
cmake "$srcdir/${pkgname%-git}" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DWITH_BULLET=ON \
- -DWITH_EIGEN=ON \
- -DWITH_GLM=ON \
- -DWITH_DART=OFF \
- -DWITH_IMGUI=ON \
+ -DMAGNUM_WITH_BULLET=ON \
+ -DMAGNUM_WITH_EIGEN=ON \
+ -DMAGNUM_WITH_GLM=ON \
+ -DMAGNUM_WITH_DART=OFF \
+ -DMAGNUM_WITH_IMGUI=ON \
-G Ninja
ninja
}