summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hanna2015-09-12 17:04:56 +0200
committerSimon Hanna2015-09-12 17:04:56 +0200
commit264eeb56d22466ed48619797a38506e62cf21462 (patch)
treed00b937309009d5aa064b437315616fba46bdee0
downloadaur-264eeb56d22466ed48619797a38506e62cf21462.tar.gz
Initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD44
-rw-r--r--mailman-core.install11
-rw-r--r--mailman.cfg11
-rw-r--r--mailman.service16
-rw-r--r--mailman.sysusers1
6 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3316bd3ffc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = mailman-core
+ pkgdesc = A mailing list management system
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://gitlab.com/mailman/mailman
+ install = mailman-core.install
+ arch = any
+ license = LGPL
+ depends = python-zope-interface
+ depends = python-zope-event
+ depends = python-zope-configuration
+ depends = python-zope-component
+ depends = python-passlib
+ depends = python-nose2
+ depends = python-httplib2
+ depends = python-flufl-lock
+ depends = python-flufl-i18n
+ depends = python-flufl-bounce
+ depends = python-falcon
+ depends = python-alembic
+ depends = python-lazr-config
+ depends = python-lazr-smtptest
+ depends = python-mock
+ depends = python-sqlalchemy
+ depends = postfix
+ conflicts = mailman
+ options = !emptydirs
+ backup = var/lib/mailman/var/etc/mailman.cfg
+ source = mailman-3.0.0.tar.gz::https://gitlab.com/mailman/mailman/repository/archive.tar.gz?ref=3.0.0
+ source = mailman.sysusers
+ source = mailman.service
+ source = mailman.cfg
+ sha256sums = 0cc28e99bbe5a8e0638f9437d1fa8490fb69634cdef30324c7a5e63719581fc2
+ sha256sums = a99bf88267184fee0568856ac09bb682224ee67029cfc20f603a43fe5f053dad
+ sha256sums = 96c8fad27e6af4272c1eaeaab77f33bb0b4bf86e4b21e0c4ceca3a5c9d37f0a8
+ sha256sums = f48dac59786be58c6a8b5fe2a12f4f356872d87600be64506f22066508847f3a
+
+pkgname = mailman-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6fee4c80db3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('mailman-core')
+_pkgbase='mailman'
+_commit=5bd0f593724f9a696bbefc91ea9c2127b66fa231
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="A mailing list management system"
+arch=(any)
+conflicts=('mailman')
+depends=('python-zope-interface' 'python-zope-event' 'python-zope-configuration'
+ 'python-zope-component' 'python-passlib' 'python-nose2' 'python-httplib2'
+ 'python-flufl-lock' 'python-flufl-i18n' 'python-flufl-bounce' 'python-falcon'
+ 'python-alembic' 'python-lazr-config' 'python-lazr-smtptest' 'python-mock'
+ 'python-sqlalchemy' 'postfix')
+url="https://gitlab.com/mailman/mailman"
+license=('LGPL')
+options=(!emptydirs)
+install=$pkgname.install
+backup=('var/lib/mailman/var/etc/mailman.cfg')
+source=("${_pkgbase}-${pkgver}.tar.gz::https://gitlab.com/mailman/mailman/repository/archive.tar.gz?ref=${pkgver}"
+ 'mailman.sysusers'
+ 'mailman.service'
+ 'mailman.cfg')
+sha256sums=('0cc28e99bbe5a8e0638f9437d1fa8490fb69634cdef30324c7a5e63719581fc2'
+ 'a99bf88267184fee0568856ac09bb682224ee67029cfc20f603a43fe5f053dad'
+ '96c8fad27e6af4272c1eaeaab77f33bb0b4bf86e4b21e0c4ceca3a5c9d37f0a8'
+ 'f48dac59786be58c6a8b5fe2a12f4f356872d87600be64506f22066508847f3a')
+
+
+package() {
+ # install systemd files
+ install -Dm 644 "${_pkgbase}.service" "$pkgdir/usr/lib/systemd/system/${_pkgbase}.service"
+ install -Dm 644 "${_pkgbase}.sysusers" "$pkgdir/usr/lib/sysusers.d/${_pkgbase}.conf"
+
+ # copy configuration file and create symlink in /etc
+ install -dm 770 "$pkgdir/var/lib/mailman"
+ install -Dm 644 "${_pkgbase}.cfg" "$pkgdir/var/lib/mailman/var/etc/${_pkgbase}.cfg"
+
+ cd "$srcdir/$_pkgbase-$pkgver-$_commit"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/mailman-core.install b/mailman-core.install
new file mode 100644
index 000000000000..c4a4572eac3d
--- /dev/null
+++ b/mailman-core.install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+post_install() {
+ # ensure correct permissions
+ systemd-sysusers mailman.conf
+ chown -R mailman:mailman /var/lib/mailman
+}
+
+post_remove() {
+ userdel mailman
+}
diff --git a/mailman.cfg b/mailman.cfg
new file mode 100644
index 000000000000..f27c000072fb
--- /dev/null
+++ b/mailman.cfg
@@ -0,0 +1,11 @@
+# This is your GNU Mailman 3 configuration file. You can edit this file to
+# configure Mailman to your needs, and Mailman will never overwrite it.
+# Additional configuration information is (for now) available in the
+# schema.cfg file <http://tinyurl.com/cm5rtqe> and the base mailman.cfg file
+# <http://tinyurl.com/dx9b8eg>.
+#
+# For example, uncomment the following lines to run Mailman in developer mode.
+#
+# [devmode]
+# enabled: yes
+# recipient: your.address@your.domain
diff --git a/mailman.service b/mailman.service
new file mode 100644
index 000000000000..37bdb1e79955
--- /dev/null
+++ b/mailman.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=GNU Mailing List Manager
+After=network.target
+
+[Service]
+User=mailman
+ExecStart=/usr/bin/mailman start
+ExecReload=/usr/bin/mailman restart
+ExecStop=/usr/bin/mailman stop
+StandardError=syslog
+Type=forking
+WorkingDirectory=/var/lib/mailman
+PIDFile=/var/lib/mailman/var/master.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/mailman.sysusers b/mailman.sysusers
new file mode 100644
index 000000000000..4df9b61f3619
--- /dev/null
+++ b/mailman.sysusers
@@ -0,0 +1 @@
+u mailman - "GNU Mailing List Manager" /var/lib/mailman