summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hanna2016-02-12 16:41:26 +0100
committerSimon Hanna2016-02-12 16:41:26 +0100
commit4e45e2418705a7067624455a4232eb73aa1482dc (patch)
tree319d10dd735415236eb405c1d7ab50a1a9fee9ab
parent4773e9c63279160cb8ee8505d4e49ce34e944e3e (diff)
downloadaur-4e45e2418705a7067624455a4232eb73aa1482dc.tar.gz
upgpkg: mailman-core 3.0.2-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66c12cb69693..d8ff78de8e96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mailman-core
pkgdesc = A mailing list management system
- pkgver = 3.0.0
+ pkgver = 3.0.2
pkgrel = 1
url = https://gitlab.com/mailman/mailman
install = mailman-core.install
arch = any
license = LGPL
+ checkdepends = python-tox
makedepends = python-setuptools
- makedepends = python2-setuptools
depends = python-zope-interface
depends = python-zope-event
depends = python-zope-configuration
@@ -29,11 +29,11 @@ pkgbase = mailman-core
conflicts = mailman
options = !emptydirs
backup = var/lib/mailman/var/etc/mailman.cfg
- source = mailman-3.0.0.tar.gz::https://gitlab.com/mailman/mailman/repository/archive.tar.gz?ref=3.0.0
+ source = mailman-3.0.2.tar.gz::https://gitlab.com/mailman/mailman/repository/archive.tar.gz?ref=3.0.2
source = mailman.sysusers
source = mailman.service
source = mailman.cfg
- sha256sums = 0cc28e99bbe5a8e0638f9437d1fa8490fb69634cdef30324c7a5e63719581fc2
+ sha256sums = a1bb7b9dc491de804168e3e8a71d0e3655072cf36f5e210f282ea998e305b721
sha256sums = a99bf88267184fee0568856ac09bb682224ee67029cfc20f603a43fe5f053dad
sha256sums = 96c8fad27e6af4272c1eaeaab77f33bb0b4bf86e4b21e0c4ceca3a5c9d37f0a8
sha256sums = f48dac59786be58c6a8b5fe2a12f4f356872d87600be64506f22066508847f3a
diff --git a/PKGBUILD b/PKGBUILD
index 90d2c8c8d7f6..a21fbf1f5b84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname=('mailman-core')
_pkgbase='mailman'
-_commit=5bd0f593724f9a696bbefc91ea9c2127b66fa231
-pkgver=3.0.0
+_commit=5ae3ef1b71b37fd82744e1fee84163a8955d3b9a
+pkgver=3.0.2
pkgrel=1
pkgdesc="A mailing list management system"
arch=(any)
conflicts=('mailman')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
+checkdepends=('python-tox')
depends=('python-zope-interface' 'python-zope-event' 'python-zope-configuration'
'python-zope-component' 'python-passlib' 'python-nose2' 'python-httplib2'
'python-flufl-lock' 'python-flufl-i18n' 'python-flufl-bounce' 'python-falcon'
@@ -20,25 +21,29 @@ license=('LGPL')
options=(!emptydirs)
install=$pkgname.install
backup=('var/lib/mailman/var/etc/mailman.cfg')
-source=("${_pkgbase}-${pkgver}.tar.gz::https://gitlab.com/mailman/mailman/repository/archive.tar.gz?ref=${pkgver}"
+source=("mailman-${pkgver}.tar.gz::https://gitlab.com/mailman/mailman/repository/archive.tar.gz?ref=${pkgver}"
'mailman.sysusers'
'mailman.service'
'mailman.cfg')
-sha256sums=('0cc28e99bbe5a8e0638f9437d1fa8490fb69634cdef30324c7a5e63719581fc2'
+sha256sums=('a1bb7b9dc491de804168e3e8a71d0e3655072cf36f5e210f282ea998e305b721'
'a99bf88267184fee0568856ac09bb682224ee67029cfc20f603a43fe5f053dad'
'96c8fad27e6af4272c1eaeaab77f33bb0b4bf86e4b21e0c4ceca3a5c9d37f0a8'
'f48dac59786be58c6a8b5fe2a12f4f356872d87600be64506f22066508847f3a')
+check() {
+ cd "$srcdir/mailman-$pkgver-$_commit"
+ tox -e py34
+}
package() {
# install systemd files
- install -Dm 644 "${_pkgbase}.service" "$pkgdir/usr/lib/systemd/system/${_pkgbase}.service"
- install -Dm 644 "${_pkgbase}.sysusers" "$pkgdir/usr/lib/sysusers.d/${_pkgbase}.conf"
+ install -Dm 644 "mailman.service" "$pkgdir/usr/lib/systemd/system/mailman.service"
+ install -Dm 644 "mailman.sysusers" "$pkgdir/usr/lib/sysusers.d/mailman.conf"
# copy configuration file and create symlink in /etc
install -dm 770 "$pkgdir/var/lib/mailman"
- install -Dm 644 "${_pkgbase}.cfg" "$pkgdir/var/lib/mailman/var/etc/${_pkgbase}.cfg"
+ install -Dm 644 "mailman.cfg" "$pkgdir/var/lib/mailman/var/etc/mailman.cfg"
- cd "$srcdir/$_pkgbase-$pkgver-$_commit"
+ cd "$srcdir/mailman-$pkgver-$_commit"
python setup.py install --root="$pkgdir/" --optimize=1
}