summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-07-28 17:30:45 +1200
committercaltlgin2020-07-28 17:30:45 +1200
commit150ae8d04afa7bbe57ce5cdf79b0757d885f6c40 (patch)
tree008e4a6b7cd9ab01a1a0c6a7403f8cf1125bc0b3
downloadaur-150ae8d04afa7bbe57ce5cdf79b0757d885f6c40.tar.gz
Add to AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..765cb5cd8771
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mailman-rss
+ pkgdesc = Mailman archive to rss/twitter bot
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/kyamagu/mailman-rss
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-dateutil
+ depends = python-future
+ depends = python-requests
+ optdepends = python-twitter: twitter bot functionality
+ source = mailman-rss-0.2.4.tar.gz::https://files.pythonhosted.org/packages/5c/b3/a4939632657d073def0d9256921178ab39da90c763b0e0fc01b2e76a9f4e/mailman-rss-0.2.4.tar.gz
+ source = mailman-rss-0.2.4-LICENSE::https://raw.githubusercontent.com/kyamagu/mailman-rss/master/LICENSE
+ sha256sums = 0030e2ba55cf77b96d8777956270909cc68b77a7d5314093ea4f7909ce8c39af
+ sha256sums = SKIP
+
+pkgname = mailman-rss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c5447df41e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=mailman-rss
+pkgver=0.2.4
+_pythonhosted_hash='5c/b3/a4939632657d073def0d9256921178ab39da90c763b0e0fc01b2e76a9f4e'
+pkgrel=1
+pkgdesc='Mailman archive to rss/twitter bot'
+arch=('any')
+url='https://github.com/kyamagu/mailman-rss'
+_rawurl='https://raw.githubusercontent.com/kyamagu/mailman-rss'
+license=('MIT')
+depends=('python-beautifulsoup4' 'python-dateutil' 'python-future' 'python-requests')
+makedepends=('python-setuptools')
+optdepends=('python-twitter: twitter bot functionality')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/${_pythonhosted_hash}/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}-${pkgver}-LICENSE::${_rawurl}/master/LICENSE")
+sha256sums=('0030e2ba55cf77b96d8777956270909cc68b77a7d5314093ea4f7909ce8c39af'
+ 'SKIP')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ install -Dm644 "${pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 'README.rst' "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim: ts=2 sw=2 et: