summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Morales2015-06-08 20:31:54 -0300
committerFelipe Morales2015-06-08 20:31:54 -0300
commitc4f13f1f96c68ffb8bb00e2413165f2a1e8963eb (patch)
tree3585083e9545c46c641446d49a250594af77770b
downloadaur-c4f13f1f96c68ffb8bb00e2413165f2a1e8963eb.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5298c355e0de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mailnot-git
+ pkgdesc = A Gmail notifier for GNOME 3
+ pkgver = 20131026
+ pkgrel = 1
+ url = http://github.com/fmoralesc/utils
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2-gobject
+ depends = python2-dateutil
+ provides = mailnot
+
+pkgname = mailnot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8409840cb05f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Felipe Morales <hel.sheep@gmail.com>
+pkgname=mailnot-git
+pkgver=20131026
+pkgrel=1
+pkgdesc="A Gmail notifier for GNOME 3"
+arch=(any)
+url="http://github.com/fmoralesc/utils"
+license=('GPL')
+groups=()
+depends=('python2-gobject' 'python2-dateutil')
+makedepends=('git')
+provides=('mailnot')
+
+_gitroot=git://github.com/fmoralesc/utils.git
+_gitname=mailnot
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -Dm755 mailnot "$pkgdir/usr/bin/mailnot"
+ install -Dm644 mailnot.desktop "$pkgdir/usr/share/applications/mailnot.desktop"
+}
+
+# vim:set ts=2 sw=2 et: