summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-01-14 17:17:09 +0100
committerDaniel Peukert2020-01-14 17:17:09 +0100
commitd9354bbd2c456f170af810084ce436029d6927ac (patch)
tree6b6b33dc0ea08a06f1dc8fd0c6872a0b63f2e5e8
parent865fd6e4f611684af1e2a35e61be1f64b6e73811 (diff)
downloadaur-d9354bbd2c456f170af810084ce436029d6927ac.tar.gz
Added mailpile
-rw-r--r--.SRCINFO29
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD78
-rw-r--r--mailpile.install34
-rw-r--r--mailpile.service2
-rw-r--r--mailpile.sysusers4
-rw-r--r--mailpile.tmpfiles1
8 files changed, 89 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a12231983fa..7b1f0b772f32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue Jun 5 22:17:46 UTC 2018
pkgbase = mailpile
- pkgdesc = A modern, fast web-mail client with user-friendly encryption and privacy features
- pkgver = 1.0.0rc3
+ pkgdesc = A free & open modern, fast email client with user-friendly encryption and privacy features
+ pkgver = 1.0.0rc6
pkgrel = 1
url = http://www.mailpile.is
- install = mailpile.install
arch = any
license = AGPL3
+ makedepends = python2-setuptools
depends = gnupg
+ depends = python2
depends = python2-appdirs
depends = python2-cryptography
depends = python2-fasteners
+ depends = python2-icalendar
+ depends = python2-imgsize
depends = python2-jinja>=2.6
depends = python2-lxml>=2.3.2
depends = python2-markupsafe
@@ -19,12 +20,18 @@ pkgbase = mailpile
depends = python2-pgpdump
depends = python2-pillow
depends = python2-pydns
- depends = python2-setuptools
- depends = spambayes>=1.1a6
- source = mailpile-1.0.0rc3.tar.gz::https://github.com/mailpile/mailpile/archive/1.0.0rc3.tar.gz
+ depends = python2-pysocks
+ depends = python2-stem>=1.4
+ depends = tor
+ source = mailpile-1.0.0rc6-1.tar.gz::https://github.com/mailpile/Mailpile/archive/1.0.0rc6.tar.gz
+ source = mailpile-1.0.0rc6-1-print.tar.gz::https://github.com/mailpile/Mailpile-print/archive/7c1372b999dd6e68710e08e16778f2986c064295.tar.gz
+ source = mailpile.sysusers
+ source = mailpile.tmpfiles
source = mailpile.service
- sha256sums = b2fd0d304b0d856588bfa4dae1820c518142ddb443c70aefa3a1d16a3682babf
- sha256sums = 07adbd61cda225bf11818d39776240ee1077a3f2ddc9e5ef0f11825dd4ca504d
+ sha256sums = db4ee7d43b049fe8ffbd99225e9be7c9d66258bb7d30636c3361de1f2a08e0e0
+ sha256sums = e35ba90ffc3f4f864765f5f8e096cc66a6a62c50e78e95c1696417baa4ea8344
+ sha256sums = 47cad07997afb1e0b7a00d686db111cf819c4b6ffdcd5c174d5b5d1c0966ea13
+ sha256sums = ddfc114acd7b926aad8ff1e3b0ce31558aef8017458e2c1c98c923ef9d4174ea
+ sha256sums = e6a49dbf34a36a46b744e07cea39b443954f430835ff988a6938a07331b9726d
pkgname = mailpile
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 61f1395c427e..6414a73d0ff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,53 @@
-# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
-# Based on the mailpile-git PKGBUILD
-# Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com>
-
-pkgname=mailpile
-pkgver=1.0.0rc3
-pkgrel=1
-pkgdesc="A modern, fast web-mail client with user-friendly encryption and privacy features"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Maxim Andersson <thesilentboatman@gmail.com>
+# Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com> (mailpile-git PKGBUILD)
+# Contributor: Frank Fishburn <frankthefishburn@gmail.com> (mailpile-git PKGBUILD)
+pkgname='mailpile'
+pkgver='1.0.0rc6'
+pkgrel='1'
+pkgdesc='A free & open modern, fast email client with user-friendly encryption and privacy features'
arch=('any')
-url="http://www.mailpile.is"
+url="http://www.$pkgname.is"
license=('AGPL3')
-depends=('gnupg' 'python2-appdirs' 'python2-cryptography' 'python2-fasteners' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pbr' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'python2-setuptools' 'spambayes>=1.1a6')
-install=${pkgname}.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mailpile/${pkgname}/archive/${pkgver}.tar.gz"
- "${pkgname}.service")
-sha256sums=('b2fd0d304b0d856588bfa4dae1820c518142ddb443c70aefa3a1d16a3682babf'
- '07adbd61cda225bf11818d39776240ee1077a3f2ddc9e5ef0f11825dd4ca504d')
+depends=('gnupg' 'python2' 'python2-appdirs' 'python2-cryptography' 'python2-fasteners' 'python2-icalendar' 'python2-imgsize' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pbr' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'python2-pysocks' 'python2-stem>=1.4' 'tor')
+makedepends=('python2-setuptools')
+_printcommit='7c1372b999dd6e68710e08e16778f2986c064295'
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/$pkgname/${pkgname^}/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-print.tar.gz::https://github.com/$pkgname/${pkgname^}-print/archive/$_printcommit.tar.gz"
+ "$pkgname.sysusers"
+ "$pkgname.tmpfiles"
+ "$pkgname.service"
+)
+sha256sums=('db4ee7d43b049fe8ffbd99225e9be7c9d66258bb7d30636c3361de1f2a08e0e0'
+ 'e35ba90ffc3f4f864765f5f8e096cc66a6a62c50e78e95c1696417baa4ea8344'
+ '47cad07997afb1e0b7a00d686db111cf819c4b6ffdcd5c174d5b5d1c0966ea13'
+ 'ddfc114acd7b926aad8ff1e3b0ce31558aef8017458e2c1c98c923ef9d4174ea'
+ 'e6a49dbf34a36a46b744e07cea39b443954f430835ff988a6938a07331b9726d')
+
+_sourcedirectory="${pkgname^}-$pkgver"
prepare() {
- cd "${srcdir}/Mailpile-${pkgver}"
-
- # Set absolute path
- sed -i '5,9c mailpile_root = "/usr/share/mailpile"' mp
-}
-
-build() {
- cd "${srcdir}/Mailpile-${pkgver}"
-
- # Compile bytecode
- python2 -m compileall -f mailpile
+ cd "$srcdir/$_sourcedirectory"
+ find . -type f -exec sed -i 's|#!/usr/bin/python|#!/usr/bin/env python2.7|g' {} \;
+ find . -type f -exec sed -i 's|#!/usr/bin/python2.7|#!/usr/bin/env python2.7|g' {} \;
+ rm -rf 'shared-data/'{mailpile-gui/,multipile/}
+ rm -rf 'shared-data/default-theme/'{less/,index.html}
+ rm -rf 'mailpile/tests'
+ # One of the plugins is a submodule and doesn't get pulled automatically, provide it manually
+ mv "$srcdir/${pkgname^}-print-$_printcommit/"* 'shared-data/contrib/print/'
}
package() {
- cd "${srcdir}/Mailpile-${pkgver}"
-
- install -d "${pkgdir}/usr/share/${pkgname}"
+ cd "$srcdir/$_sourcedirectory"
+ # The folder structure breaks when we build and install separately for some reason
+ python2 setup.py install --root="$pkgdir/"
- cp -r shared-data/* "${pkgdir}/usr/share/${pkgname}/"
- cp -r mailpile "${pkgdir}/usr/share/${pkgname}/"
+ install -dm755 "$pkgdir/usr/bin"
+ ln -sf "/usr/bin/$pkgname" "$pkgdir/usr/bin/mp"
- install -D mp -t "${pkgdir}/usr/bin"
- install -Dm644 "../${pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system"
+ install -Dm644 "../$pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -Dm644 "../$pkgname.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+ install -Dm644 "../$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
+ install -Dm644 "packages/$pkgname.1" "$pkgdir/usr/share/man/man8/$pkgname.8"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/mailpile.install b/mailpile.install
deleted file mode 100644
index fbfbd5a709ca..000000000000
--- a/mailpile.install
+++ /dev/null
@@ -1,34 +0,0 @@
-post_install() {
- post_upgrade $1
-
- echo ""
- echo "==> Note: Mailpile is still in development and not"
- echo "==> suitable for production or end-user use."
- echo ""
- echo "==> Get more info at:"
- echo "==> https://github.com/pagekite/Mailpile/wiki/Getting-started"
- echo ""
-}
-
-# arg 2: the old package version
-post_upgrade() {
- if ! getent group mailpile >/dev/null; then
- groupadd --system mailpile
- fi
-
- if ! getent passwd mailpile >/dev/null; then
- useradd --system -c 'mailpile daemon user' -g mailpile -b /var/lib -m -s /bin/bash mailpile >/dev/null 2>&1
- elif ! test -d /var/lib/mailpile; then
- mkhomedir_helper mailpile
- fi
-
- if test $2 && test "`vercmp $2 0.4.1-1`" -lt 0; then
- echo '==> Mailpile home directory has moved to /var/lib/mailpile'
- fi
-}
-
-post_remove() {
- systemctl stop mailpile >/dev/null 2>&1
-
- echo "==> Note: /var/lib/mailpile may still contain data"
-}
diff --git a/mailpile.service b/mailpile.service
index 51a110552a74..5bcab5d55a59 100644
--- a/mailpile.service
+++ b/mailpile.service
@@ -8,7 +8,7 @@ User=mailpile
PIDFile=/run/mailpile.pid
PrivateTmp=true
Environment=MAILPILE_HOME=/var/lib/mailpile
-ExecStart=/usr/bin/mp --www= --wait
+ExecStart=/usr/bin/mailpile --www= --wait
[Install]
WantedBy=multi-user.target
diff --git a/mailpile.sysusers b/mailpile.sysusers
new file mode 100644
index 000000000000..6fd4e8dd549f
--- /dev/null
+++ b/mailpile.sysusers
@@ -0,0 +1,4 @@
+# Type Name ID GECOS Home directory Shell
+g mailpile - -
+u mailpile - "mailpile daemon user" /var/lib/mailpile /bin/bash
+m mailpile mailpile
diff --git a/mailpile.tmpfiles b/mailpile.tmpfiles
new file mode 100644
index 000000000000..1a9a3eb6323e
--- /dev/null
+++ b/mailpile.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/mailpile 0755 mailpile mailpile