summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDalton Nell2015-07-11 15:33:05 -0600
committerDalton Nell2015-07-11 15:33:05 -0600
commita56d142b4ee8b5450a3c1de543a7e0164f6d4b59 (patch)
tree6f1ae45b65d153c5ac2bebbfa82e487ed860206b
downloadaur-a56d142b4ee8b5450a3c1de543a7e0164f6d4b59.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD32
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e8bea835bc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = maim-git
+ pkgdesc = maim (make image) makes an image out of the given area on the given X screen. Defaults to the whole screen.
+ pkgver = v3.4.43.r0.g2e5ed5b
+ pkgrel = 1
+ url = https://github.com/naelstrof/maim
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = make
+ makedepends = gcc
+ makedepends = cmake
+ depends = bzip2
+ depends = freetype2
+ depends = glibc
+ depends = imlib2
+ depends = libx11
+ depends = libxext
+ depends = zlib
+ optdepends = slop-git: for selection support
+ conflicts = maim
+ source = maim::git+https://github.com/naelstrof/maim.git
+ md5sums = SKIP
+
+pkgname = maim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc2df80742ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: naelstrof <naelstrof@gmail.com>
+pkgname=maim-git
+_realname=maim
+pkgver=v3.4.43.r0.g2e5ed5b
+pkgrel=1
+conflicts=( 'maim' )
+pkgdesc="maim (make image) makes an image out of the given area on the given X screen. Defaults to the whole screen."
+arch=( 'i686' 'x86_64' )
+url="https://github.com/naelstrof/$_realname"
+license=( 'GPL3' )
+depends=( 'bzip2' 'freetype2' 'glibc' 'imlib2' 'libx11' 'libxext' 'zlib' )
+optdepends=( 'slop-git: for selection support' )
+makedepends=( 'make' 'gcc' 'cmake' )
+source=( "maim::git+https://github.com/naelstrof/maim.git" )
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_realname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_realname"
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" ./
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname"
+
+ make install
+}