summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Dobachesky2019-03-23 14:59:47 -0400
committerMichael Dobachesky2019-03-23 14:59:47 -0400
commit5db86c597d36b0c4657bfa5c39e6cfe872a6229e (patch)
tree6eeb07bd4e58f02c5763997882e8c9fee04345d6
parent6c70c0eaf5dbae537d952410f3bc51c5106ffbee (diff)
downloadaur-5db86c597d36b0c4657bfa5c39e6cfe872a6229e.tar.gz
move directory creation to prepare function
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4b2504428d3..429ef3a2ee1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,11 +35,13 @@ source=("https://gitlab.com/mgdobachesky/ArchSystemMaintenance/raw/master/pkg/$p
md5sums=('a8f2dbb84545be4ee71c81e9e33433b6')
-build() {
+prepare() {
umask 022
mkdir -p "$_install_dir/ui" "$_install_dir/other"
mkdir -p "$_symlink_dir"
+}
+build() {
install -m 755 "other/archNews.py" "$_install_dir/other"
install -m 755 "ui/cli.sh" "$_install_dir/ui"
install -m 755 "ui/nCurses.sh" "$_install_dir/ui"