summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-18 23:48:16 +0800
committerChocobo12017-08-19 00:02:02 +0800
commit7867cbbbc85a603200b538f7d34fe8b33f970ce6 (patch)
treeace68c936eec7820d8fa844dcc96f95a20f81a0b
downloadaur-7867cbbbc85a603200b538f7d34fe8b33f970ce6.tar.gz
newpkg: make-git 4.2.1.r50.g7ef56bc-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3dfc3639505
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = make-git
+ pkgdesc = A tool which controls the generation of executables and other non-source files of a program from the program's source files
+ pkgver = 4.2.1.r50.g7ef56bc
+ pkgrel = 1
+ url = https://www.gnu.org/software/make/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rsync
+ makedepends = wget
+ depends = glibc
+ depends = guile
+ provides = make
+ conflicts = make
+ source = git+https://git.savannah.gnu.org/git/make.git
+ sha256sums = SKIP
+
+pkgname = make-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0da77f961c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=make-git
+pkgver=4.2.1.r50.g7ef56bc
+pkgrel=1
+pkgdesc="A tool which controls the generation of executables and other non-source files of a program from the program's source files"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/make/"
+license=('GPL3')
+depends=('glibc' 'guile')
+makedepends=('git' 'rsync' 'wget')
+provides=('make')
+conflicts=('make')
+source=("git+https://git.savannah.gnu.org/git/make.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "make"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "make"
+
+ autoreconf -fi
+ ./configure --prefix="/usr" --with-guile
+ make update
+ make
+}
+
+check() {
+ cd "make"
+
+ make check
+}
+
+package() {
+ cd "make"
+
+ make DESTDIR="$pkgdir" install
+}