summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurizio D'Addona2021-12-29 11:31:55 +0100
committerMaurizio D'Addona2021-12-29 11:31:55 +0100
commit8c3e58702c16ce02bdc8f00782b14a448c1bbc79 (patch)
treea1556ebcc25622628120e26d9e8a72e6b7e330e0
parent0bd0193dc21069d2f97bc8fab773e71a35d73304 (diff)
downloadaur-8c3e58702c16ce02bdc8f00782b14a448c1bbc79.tar.gz
Enables optional compression algorithms
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 315824b806d0..67215252159e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = makedumpfile
pkgdesc = A tool to generate smaller dumpfiles from kdump memory dumps
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/makedumpfile/makedumpfile
arch = i686
arch = x86_64
license = GPL2
+ makedepends = zstd
+ makedepends = lzo
+ makedepends = snappy
depends = perl
depends = elfutils
+ optdepends = zstd: for zstd compression
+ optdepends = lzo: for lzo compression
+ optdepends = snappy: for snappy compression
source = https://github.com/makedumpfile/makedumpfile/releases/download/1.7.0/makedumpfile-1.7.0.tar.gz
sha256sums = 8985f8df249087ea68c6051dec6dac3ef0703fe2aa87d0266f3951f93aa8da5e
diff --git a/PKGBUILD b/PKGBUILD
index beb15d140a65..53b8f3f8d5f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,18 @@
# Contributor: Mathieu Pasquet <mathieui@mathieui.net>
# Contributor: Bernhard Walle <bernhard.walle@gmx.de>
# Contributor: Michael Eckert <michael.eckert@linuxmail.org>
+# Contributor: Guilherme G. Piccoli <gpiccoli@igalia.com>
pkgname=makedumpfile
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A tool to generate smaller dumpfiles from kdump memory dumps"
license=('GPL2')
depends=('perl' 'elfutils')
+makedepends=('zstd' 'lzo' 'snappy')
+optdepends=('zstd: for zstd compression'
+ 'lzo: for lzo compression'
+ 'snappy: for snappy compression')
arch=('i686' 'x86_64')
url="https://github.com/makedumpfile/makedumpfile"
source=("https://github.com/makedumpfile/makedumpfile/releases/download/${pkgver}/makedumpfile-${pkgver}.tar.gz")
@@ -17,7 +22,7 @@ sha256sums=('8985f8df249087ea68c6051dec6dac3ef0703fe2aa87d0266f3951f93aa8da5e')
build() {
cd $srcdir/$pkgname-$pkgver
export CFLAGS="-fcommon"
- make LINKTYPE=dynamic
+ make LINKTYPE=dynamic USEZSTD=on USELZO=on USESNAPPY=on
}
package() {