summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortelans2019-10-19 09:56:12 +1300
committertelans2019-10-19 09:56:12 +1300
commit43f94f2ba1ffe25cfb9b4a756bde0eaefa9e23db (patch)
treec6337ed06977298719fbb84c4669867e80a032eb
parentdae351ff3cd2d68d3e7e9fce58a9412cd30738de (diff)
downloadaur-43f94f2ba1ffe25cfb9b4a756bde0eaefa9e23db.tar.gz
0.9.6-1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore9
-rw-r--r--CHANGELOG357
-rw-r--r--PKGBUILD4
-rw-r--r--changelog150
5 files changed, 368 insertions, 158 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd305a776d18..5a8191eebd3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = makemetapkg
pkgdesc = Create meta-packages for pacman
- pkgver = 0.9.5
+ pkgver = 0.9.6
pkgrel = 1
url = https://gitlab.com/ayekat/pacman-hacks
- changelog = changelog
+ changelog = CHANGELOG
arch = any
license = GPL3
makedepends = asciidoc
makedepends = git
depends = coreutils
conflicts = remakepkg
- source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.9.5
+ source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.9.6
sha256sums = SKIP
pkgname = makemetapkg
diff --git a/.gitignore b/.gitignore
index 366e1ae483c6..4c9463123b86 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
-/pacman-hacks/
-/src/
-/pkg/
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!CHANGELOG
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..337e0bc5feda
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,357 @@
+================================================================================
+v0.9.6 (released on: 2019-10-08)
+
+REPKG:
+ * Improvements:
+ - When unpacking package files, ignore platform-specific file flags that may
+ lead to errors depending on the used filesystem.
+
+- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+v0.9.5 (released on: 2019-08-02)
+
+REMAKEPKG
+ * Bug fixes:
+ - Don't exit with error code on success (if -k is not passed).
+
+ZR
+ * Bug fixes:
+ - Fix crash caused by unset variable.
+ - Don't invoke expac on a non-existing package file.
+
+
+- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+v0.9.4 (released on: 2019-07-31)
+
+MISCELLANEOUS/INTERNAL:
+ * Bug fixes:
+ - Makefile: Fix getpkg.1 installation
+
+
+- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+v0.9.3 (released on: 2019-07-31)
+
+REMAKEPKG
+ * Bug fixes:
+ - Download correct version of package with -b.
+
+
+- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+v0.9.2 (released on: 2019-07-26)
+
+REPKG
+ * Bug fixes:
+ - Fix crash in expect-{arch,desc,name,url} due to unset variables.
+
+
+- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+v0.9.1 (released on: 2019-07-25)
+
+MISCELLANEOUS/INTERNAL
+ * Bug fixes:
+ - Makefile: remove trailing reference to lib/string.sh.
+
+
+================================================================================
+v0.9 (released on: 2019-07-22)
+
+DIFFREPO
+ * Changes/Deprecations:
+ - Change -r option to -R, to be more in line with repkg.
+ * Improvements:
+ - Optimise comparison (fewer calls to pacman/expac, therefore faster).
+ * Additions:
+ - Add -b option to specify an alternative pacman package db location.
+
+FETCHPKG (new)
+ getpkg renamed to this.
+ * Additions:
+ - Add -b option to specify an alternative pacman package db location.
+
+GETPKG (deprecated)
+ fetchpkg (new) should be used now.
+
+METAPKG
+ * Bug fixes:
+ - Don't crash when XDG_CONFIG_HOME is unset.
+
+PACWHY (deprecated)
+ pactree (from pacman-contrib) should be used instead.
+
+PKGMIRROR
+ * Additions:
+ - Add -b option to specify an alternative pacman package db location.
+
+REMAKEPKG
+ * Bug fixes:
+ - remakepkg(1): Fix name of (hardcoded) directory used for rebuilding
+ packages.
+ * Improvements:
+ - Less verbose output by default (pass -d to see them all).
+ - Better error message format.
+ - More helpful -h message for -k option.
+ - For -k, save files to current working directory rather than pkg/.
+ * Additions:
+ - Add -b option to specify an alternative pacman package db location.
+
+REPKG
+ * Bug fixes:
+ - Fix false dependency conflicts caused by wrong package name matching.
+ - Properly update arch in output filename.
+ - Properly update package installation size.
+ - Support packages with files like /* or any hidden files directly in /.
+ - Check if parent directory exists (for create-file).
+ - Don't expect the user's makepkg.conf to exist.
+ * Changes/Deprecations:
+ - Rename change-mode to change-file-mode.
+ * Improvements:
+ - Less verbose output by default (pass -d to see them all).
+ - Better error message format.
+ - Be stricter and less verbose when patching.
+ - Allow absolute paths for patch files.
+ * Additions:
+ - Add set-name and set-desc commands for setting package name/description.
+ - Add change-file-uid and change-file-gid commands for setting file
+ ownership.
+ - Add add-file command for adding a file to the package.
+ - Add expect-… commands for performing various checks.
+
+MISCELLANEOUS/INTERNALS
+ * Removals:
+ - Remove lib/bool.sh, as booleans are now handled differently.
+ - Remove lib/string.sh, as it is not required by any script.
+ * Additions:
+ - Add lib/pacman.sh for dealing with alternative package DB locations
+ (required by diffrepo, fetchpkg, pkgmirror and remakepkg).
+
+
+================================================================================
+v0.8 (released on: 2019-06-10)
+
+GETPKG:
+ * Bug fixes:
+ - Properly fail on 404.
+
+METAPKG
+ * Bug fixes:
+ - Fix documentation for groups.
+ - Don't expect the user's makepkg.conf to exist.
+
+REPKG
+ * Bug fixes:
+ - Properly handle *non*-versioned depends/conflicts/provides/replaces.
+ - Fix path-related issues for remove-backup and rename-file.
+ - repkg(1): Fix note about mandatory options.
+
+ZR
+ * Changes/Deprecations:
+ - Use mappings for `zr add` (instead of declaring repo on command line).
+ * Additions:
+ - Add support for mappings.ini, to map packages to repositories.
+ - Add `map` command to show which repository a package is mapped to.
+
+MISCELLANEOUS/INTERNALS
+ * Bug fixes:
+ - Makefile: Fix PREFIX_… variable declarations.
+ - Makefile: Force rebuilding files containing software version.
+ - Makefile: Fix target dependencies to allow multithreaded building.
+ - Readme: Fix list of dependencies.
+ * Improvements:
+ - pacred: Use coreutils' `comm` instead of diffutils' `diff`
+ (-1 dependency).
+ - pkgmirror: Use pacman-conf to obtain package URL.
+
+
+================================================================================
+v0.7 (released on: 2018-09-18)
+
+CHECKRESTART
+ * Changes/Deprecations:
+ - Ignore /usr/share/{icons/hicolor/icon-theme,mime/mime}.cache
+
+METAPKG
+ * Bug fixes:
+ - Correctly print info messages for optional dependencies.
+ - Correctly generate conflicts/provides/replaces in PKGBUILD.
+ - Fix relative paths for output files.
+ - Properly escape special characters in descriptions and optdepends.
+
+REMAKEPKG
+ * Bug fixes:
+ - Don't test for (wrong) output file existence.
+ - Handle and forward repkg's -R correctly.
+
+REPKG
+ * Improvements:
+ - Automatically add provision for old package version/release (retains
+ compatibility for versioned dependencies).
+ - Add support for versioned depends/conflicts/provides/replaces.
+
+
+================================================================================
+v0.6 (released on: 2018-06-24)
+
+METAPKG
+ * Additions:
+ - Add `conflicts`/`provides`/`replaces`.
+
+PACRED
+ * Bug fixes:
+ - Don't treat base-devel specially
+
+REPKG
+ * Bug fixes:
+ - Correctly propagate errors from failing subroutines.
+ - Fix file check that could lead to incomplete/empty packages.
+ * Changes/Deprecations:
+ - `-o` now takes output *directory* as argument (filename is derived).
+ - Packages now get a dotted suffix for the pkgrel.
+
+ZR
+ * Changes/Deprecations:
+ - Repository profiles are now read from $XDG_CONFIG_HOME/zr/repos.
+
+
+================================================================================
+v0.5 (released on: 2018-04-16)
+
+DIFFREPO
+ * Additions:
+ - Add -n option to ignore/negate specific packages in a repository.
+
+MAKEMETAPKG (new)
+ Higher-level wrapper around metapkg (uses METAPKGBUILD files).
+
+METAPKG (new)
+ Generate meta-packages from compact rule files.
+
+REMAKEPKG
+ * Additions:
+ - Add -i option for specifying alternative REPKGBUILD file.
+
+REPKG
+ * Bug fixes:
+ - Fix unquoted variable (XDG_CONFIG_HOME).
+ * Changes/Deprecations:
+ - Drop functionality that reads rules from standard input (so `-r` is now
+ mandatory).
+ * Additions:
+ - Add add-group and remove-group commands.
+
+MISCELLANEOUS/INTERNAL
+ * Bug fixes:
+ - lib/bool.sh: Fix syntax error.
+ * Improvements
+ - Readme: Change description a bit ("simplify" → "complement").
+
+================================================================================
+v0.4 (released on: 2018-03-12)
+
+GETPKG
+ * Addition:
+ - Add -o option to specify alternative download file name.
+
+REMAKEPKG (new)
+ Wrapper around getpkg and repkg to easily rebuild a package.
+
+REPKG
+ Make it more low-level and intended for use with remakepkg.
+ * Bug fixes:
+ - Correctly update packager and build date as well
+ - Don't accept "empty line" or "comment" after a package name (instead
+ of a command).
+ * Changes/Deprecations:
+ - No global rules file anymore (see Additions section for new options).
+ * Additions:
+ - Add -r option for specifying rules file.
+ - Add -i option for specifying input package file.
+ - Add -o option for specifying output package file.
+ - Add set-arch and set-url commands.
+
+ZR
+ * Improvements:
+ - Group together the addition of files to a repo to make it faster.
+ * Bug fixes:
+ - Correctly add package to the remote database if invoked with -f.
+ - Don't redundantly print naked name of files to be removed.
+
+MISCELLANEOUS/INTERNAL
+ * Bug fixes:
+ - Show project commit date in man pages, not build date.
+
+
+================================================================================
+v0.3 (released on: 2018-02-26)
+
+The project is renamed from pacman-contrib-zuepfe to pacman-hacks.
+
+DIFFREPO (new)
+ List version differences between packages in multiple repositories.
+
+GETPKG (new)
+ Download a package from a mirror.
+
+PACBLOAT (removed)
+ pacman -Qet should be used instead (especially since base-devel is now a
+ meta-package).
+
+PKGMIRROR (new)
+ List mirror download URLs for a package.
+
+REPKG (new)
+ Apply modifications to package files.
+
+ZR
+ * Bug fixes:
+ - Fix argument handling for -p.
+ * Changes/Deprecations:
+ - Now invoked as `zr add {package} {repo}` and `zr rm {repo}/{package}`.
+ * Additions:
+ - Add `ls` subcommand for listing known/configured repositories.
+
+MISCELLANEOUS/INTERNAL
+ * Additions
+ - All scripts now provide a -h option for help output.
+
+
+================================================================================
+v0.2 (released on: 2018-02-09)
+
+The project is renamed from zr to pacman-contrib-zuepfe. It is now a repository
+containing various package maintenance related scripts (most imported from the
+utils repository).
+
+ABS (new)
+ Fetch package sources for official packages.
+
+ALA (new)
+ Download old packages from the Arch Linux Archive (ALA).
+
+AUR (new)
+ Fetch package sources from the AUR.
+
+CHECKRESTART
+ List processes using libraries/system files that no longer exist.
+
+PACBLOAT
+ List explicitly installed packages that are not required by any other package
+ and that are not part of base-devel.
+
+PACRED
+ List explicitly installed packages that are also required by an other package.
+
+PACWHY
+ List reverse dependency tree for a package.
+
+ZR
+ * Changes/Deprecations:
+ - Don't ask for confirmation when removing old packages (we assume our match
+ is always right).
+ * Improvements:
+ - Sign packages locally (before copying) for less bandwidth usage
+
+
+================================================================================
+v0.1 (released on: 2017-12-15)
+
+Initial release as `zr`: A small, dead-simple script to manage personal, remote
+Arch Linux package repository databases.
diff --git a/PKGBUILD b/PKGBUILD
index 4856e4431a6b..eb673b5a813e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tinu Weber <http://ayekat.ch>
pkgname=makemetapkg
-pkgver=0.9.5
+pkgver=0.9.6
pkgrel=1
arch=(any)
@@ -17,7 +17,7 @@ conflicts=(remakepkg)
depends=(coreutils)
makedepends=(asciidoc git)
-changelog='changelog'
+changelog='CHANGELOG'
source=("git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v$pkgver")
sha256sums=(SKIP)
diff --git a/changelog b/changelog
deleted file mode 100644
index 3d848b9209f5..000000000000
--- a/changelog
+++ /dev/null
@@ -1,150 +0,0 @@
-v0.9.5-1 (2019-08-02)
-* New package maintainer, 'telans'
-* Bug fixes from v0.8.1 through v0.9.5
-
-v0.8-1 (2019-06-10)
-* Readme: Fix list of dependencies (bugfix)
-* More bug fixes as in v0.7.1--v0.7.8
-
-v0.7.8-1 (2019-05-13)
-* Makefile: Fix target dependencies to allow multithreaded building
-* metapkg: Fix documentation for groups
-* metapkg: Don't expect the user's makepkg.conf to exist
-* man pages: Clarify/improve some sections
-
-v0.7.7-2 (2019-05-12)
-* Initial packaging of makemetapkg
-
-v0.7.7-1 (2019-05-06)
-* Makefile: Fix targets dependency order for generating scripts/manpage/libs
-
-v0.7.6-1 (2019-03-18)
-* repkg: Fix file path for existence check in rename-file
-
-v0.7.5-1 (2019-03-16)
-* Makefile: Properly state dependencies for generating the prefix file
-
-v0.7.4-1 (2019-03-05)
-* repkg: Fix path related issues for remove-backup and rename-file
-
-v0.7.3-1 (2018-09-24)
-* Makefile: Fix PREFIX_… variable declarations - more
-
-v0.7.2-1 (2018-09-23)
-* Makefile: Fix PREFIX_… variable declarations
-* Makefile: Force rebuilding files containing software version
-
-v0.7.1-1 (2018-09-19)
-* PKGBUILD: Add provides and conflicts for provided scripts
-
-v0.7.1-1 (2018-09-18)
-* repkg: Properly handle *non*-versioned depends/conflicts/provides/replaces
-
-v0.7-1 (2018-09-18)
-* Split from pacman-hacks PKGBUILD, only package remakepkg + required scripts
-* repkg: Automatically add provision for old package version/release
-* repkg: Properly handle versioned depends/conflicts/provides/replaces
-* Bug fixes as in v0.6.1, v0.6.2, v0.6.3, v0.6.4 and v0.6.5
-
-v0.6.5-3 (2018-08-27)
-* pacman-hacks-build: Add versioned dependency on pacman-hacks
-* Add provides and conflicts for all included scripts
-
-v0.6.5-2 (2018-08-25)
-* Clean rebuild (for man pages)
-
-v0.6.5-1 (2018-08-22)
-* metapkg: Properly escape special characters in description strings
-
-v0.6.4-1 (2018-08-17)
-* metapkg: Properly generate conflicts/provides/replaces lines in PKGBUILD
-* metapkg: Fix output file location when being passed a relative path
-
-v0.6.3-1 (2018-08-07)
-* metapkg: Print info message for optional dependencies as well
-
-v0.6.2-1 (2018-06-24)
-* remakepkg: Add forgotten command line option -R
-
-v0.6.1-1 (2018-06-24)
-* remakepkg: Don't check for (wrong) output file existence
-
-v0.6-1 (2018-06-24)
-* metapkg: Add conflicts/provides/replaces
-* repkg: -o now takes an output *directory* (instead of output *filename*)
-* repkg: Packages now get a dotted suffix for the pkgrel
-* zr: Repository profiles are now read from $XDG_CONFIG_HOME/zr/repos
-* Bug fixes as in v0.5.1 and v0.5.2
-
-v0.5.2-1 (2018-06-24)
-* repkg: Fix error handling + file check that could lead to incomplete packages
-
-v0.5.1-4 (2018-06-14)
-* Remove unnecessary conflicts and provides
-
-v0.5.1-3 (2018-06-12)
-* Fix typo in install script
-
-v0.5.1-2 (2018-06-12)
-* Split build scripts into separate -build package
-
-v0.5.1-1 (2018-06-10)
-* pacred: Don't treat base-devel specially
-
-v0.5-1 (2018-04-16)
-* Add metapkg, a tool to generate meta-packages from compact rule files
-* Add makemetapkg, a wrapper around to build meta-packages using a METAPKGBUILD
-* Change project description a bit ("simplify" → "complement")
-* repkg: Drop functionality that reads rules from stdin (-r is now mandatory)
-* repkg: Add `add-group`/`remove-group`
-* diffrepo: Add -n to ignore/negate specific packages in a repository
-* Bug fixes as in v0.4.1 and v0.4.1.1
-
-v0.4.1.1-1 (2018-03-18)
-* Fix version information in help output and man pages
-
-v0.4.1-1 (2018-03-18)
-* Fix syntax error in library file
-* repkg: Handle spaces in XDG_CONFIG_HOME correctly
-
-v0.4-1 (2018-03-13)
-* Add remakepkg, a wrapper around repkg to repackage packages using a REPKGBUILD
-* repkg has a slightly different invocation syntax syntax now (more "low-level")
-* repkg: Add `set-arch` and `set-url` commands
-* repkg: Correctly update packager information
-* getpkg: Add -o option to specify output file
-* zr: Bulk-addition speed improved
-* Bug fixes as in v0.3.1, v0.3.2, v0.3.3 and v0.3.4
-
-v0.3.4-1 (2018-03-08)
-* zr: Don't print raw file names that are deleted
-
-v0.3.3-1 (2018-03-05)
-* zr: Correctly overwrite package in database as well if invoked with -f
-
-v0.3.2-1 (2018-03-03)
-* man pages: Use commit date, not build date
-
-v0.3.1-1 (2018-03-03)
-* repkg: Don't accept "empty command" or comment after a package name
-
-v0.3-1 (2018-02-26)
-* Add `-h` command line option (and help output) to all scripts
-* zr: Change argument format (`zr add package repo` and `zr rm repo/package`)
-* zr: Add `ls` subcommand
-* New scripts: diffrepo, getpkg, pkgmirror, repkg
-* Removed scripts: pacbloat
-* Bug fixes as in v0.2.1 and v0.2.2
-
-v0.2.2-1 (2018-02-12)
-* Project renamed from pacman-contrib-zuepfe to pacman-hacks
-
-v0.2.1-1 (2018-02-09)
-* zr: Fix argument handling
-
-v0.2-1 (2018-02-09)
-* Project renamed from zr to pacman-contrib-zuepfe
-* Add abs, ala, aur, checkrestart, pacbloat, pacred and pacwhy
-
-v0.1-1 (2017-12-16)
-* Initial release as zr