summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-06-30 00:37:14 +0200
committerFabioLolix2022-06-30 00:37:14 +0200
commit70ffc3d7ef3e94b0270906bd7606be8a3bb64e23 (patch)
treebc137b5b5f3d1101d1f4a955fc61863496d8a346
parent1994ef8a643b04b429224041ab8dbba201d0336d (diff)
downloadaur-70ffc3d7ef3e94b0270906bd7606be8a3bb64e23.tar.gz
v1.17.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b71b21bdcb80..2bc0d5cdedf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,27 @@
pkgbase = makemkv
- pkgdesc = DVD and Blu-ray to MKV converter and network streamer
- pkgver = 1.16.7
+ pkgdesc = DVD and Blu-ray to MKV converter
+ pkgver = 1.17.0
pkgrel = 1
url = https://www.makemkv.com
install = makemkv.install
- arch = i686
arch = x86_64
+ arch = i686
license = LGPL
license = MPL
license = custom
depends = qt5-base
- depends = libxkbcommon-x11
- depends = hicolor-icon-theme
- depends = icu
depends = ffmpeg
- optdepends = lib32-glibc: dts support
- optdepends = ccextractor: extract CC streams from some DVD media
- source = https://www.makemkv.com/download/makemkv-bin-1.16.7.tar.gz
- source = https://www.makemkv.com/download/makemkv-oss-1.16.7.tar.gz
+ optdepends = java-runtime
+ source = https://www.makemkv.com/download/makemkv-bin-1.17.0.tar.gz
+ source = https://www.makemkv.com/download/makemkv-oss-1.17.0.tar.gz
source = makemkv.1
source = makemkvcon.1
source = mmdtsdec.1
- sha256sums = 623b185b6326cc366a38c75896a134759dfdf50abc849450f4109588d7b12c7b
- sha256sums = 4cbd0f44ffe90e0d7aaac6d88bd458c83d1e80d0dac6e029991f3a86247f46af
+ sha256sums = e277d75722aede64ac1b564969c7d64608e00591b17068dc7a88358e7a03e2c0
+ sha256sums = ede75c7cc05dbef9d2e5c55d340dc090f58b25b0c809e2345c2554f0b20cf75f
sha256sums = 5573b2e4bade10d8cd258a7c235eb46f66ef8c8c97e5d5eb090c38fa0f94389b
sha256sums = f12c0facf2f0071a9f728b138986f0a4c2b4ff6ace2dfb2e96364e215e9fda6f
sha256sums = 2a6237d3d5ce073734c658c7ec5d2141ecd0047e6d3c45d1bd594135c928878f
+ optdepends_x86_64 = lib32-glibc: dts support
pkgname = makemkv
diff --git a/PKGBUILD b/PKGBUILD
index 3ec2189ed349..e8add71c9095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Marcel Korpel <marcel[dot]korpel[at]gmail>
# Contributor: Olaf Bauer <hydro@freenet.de>
pkgname=makemkv
-pkgver=1.16.7
+pkgver=1.17.0
pkgrel=1
-pkgdesc="DVD and Blu-ray to MKV converter and network streamer"
-arch=('i686' 'x86_64')
+pkgdesc="DVD and Blu-ray to MKV converter"
+arch=(x86_64 i686)
url="https://www.makemkv.com"
-license=('LGPL' 'MPL' 'custom')
-depends=('qt5-base' 'libxkbcommon-x11' 'hicolor-icon-theme' 'icu' 'ffmpeg')
-if [ "$CARCH" = "x86_64" ]; then
- optdepends=('lib32-glibc: dts support'
- 'ccextractor: extract CC streams from some DVD media')
-fi
+license=(LGPL MPL custom)
+depends=(qt5-base ffmpeg)
+optdepends=(java-runtime)
+optdepends_x86_64=('lib32-glibc: dts support')
install=makemkv.install
source=(${url}/download/${pkgname}-bin-${pkgver}.tar.gz
${url}/download/${pkgname}-oss-${pkgver}.tar.gz
makemkv.1
makemkvcon.1
mmdtsdec.1)
-sha256sums=('623b185b6326cc366a38c75896a134759dfdf50abc849450f4109588d7b12c7b'
- '4cbd0f44ffe90e0d7aaac6d88bd458c83d1e80d0dac6e029991f3a86247f46af'
+sha256sums=('e277d75722aede64ac1b564969c7d64608e00591b17068dc7a88358e7a03e2c0'
+ 'ede75c7cc05dbef9d2e5c55d340dc090f58b25b0c809e2345c2554f0b20cf75f'
'5573b2e4bade10d8cd258a7c235eb46f66ef8c8c97e5d5eb090c38fa0f94389b'
'f12c0facf2f0071a9f728b138986f0a4c2b4ff6ace2dfb2e96364e215e9fda6f'
'2a6237d3d5ce073734c658c7ec5d2141ecd0047e6d3c45d1bd594135c928878f')
@@ -33,12 +32,12 @@ build() {
package() {
cd "${srcdir}/${pkgname}-oss-${pkgver}"
- make DESTDIR=\""${pkgdir}"\" install
+ make DESTDIR="${pkgdir}" install
cd "${srcdir}/${pkgname}-bin-${pkgver}"
install -d tmp
echo accepted > tmp/eula_accepted
- make DESTDIR=\""${pkgdir}"\" install
+ make DESTDIR="${pkgdir}" install
install -Dm 644 src/eula_en_linux.txt "${pkgdir}/usr/share/licenses/${pkgname}/eula_en_linux.txt"