summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrick Brennan2023-03-31 00:45:30 -0400
committerFredrick Brennan2023-03-31 00:45:30 -0400
commitb4c5f40b8aba6e4a60f5f5ff8892b949685a9314 (patch)
treedc0ad7157258f5cac3199537e6b3a2f1e47e9d89
downloadaur-b4c5f40b8aba6e4a60f5f5ff8892b949685a9314.tar.gz
v0.1.0.pre
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72a7eaa36252
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = makepkg-cg
+ pkgdesc = A makepkg wrapper using Control Groups via systemd.resource-control
+ pkgver = 0.1.0.pre
+ pkgrel = 1
+ url = https://github.com/ctrlcctrlv/makepkg-cg
+ arch = any
+ license = Apache
+ depends = systemd
+ depends = bash
+ source = https://github.com/ctrlcctrlv/makepkg-cg/archive/refs/tags/v0.1.0.pre.tar.gz
+ sha256sums = c1983fedd56034f68d695b5a1b09fdbcc3abbe2d6fae9569a48164143f612d27
+
+pkgname = makepkg-cg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bacc3387765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Fredrick R. Brennan <copypaste@kittens.ph>
+
+pkgname=makepkg-cg
+_ghuser=ctrlcctrlv
+pkgver='0.1.0.pre'
+pkgrel=1
+pkgdesc="A makepkg wrapper using Control Groups via systemd.resource-control"
+arch=('any')
+url="https://github.com/ctrlcctrlv/makepkg-cg"
+license=('Apache')
+depends=('systemd' 'bash')
+source=("https://github.com/$_ghuser/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('c1983fedd56034f68d695b5a1b09fdbcc3abbe2d6fae9569a48164143f612d27')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cp doc/makepkg-cg.conf "${srcdir}/"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # CFLAGS="" make
+
+ # Install the makepkg-cg script
+ install -Dm755 makepkg-cg "${pkgdir}/usr/bin/makepkg-cg"
+
+ # Install the eBPF program
+ # install -Dm755 makepkg-cg-prio/makepkg-cg-prio.bpf.o "${pkgdir}/usr/share/makepkg-cg/makepkg-cg-prio.bpf.o"
+
+ # Install the makepkg-cg configuration file
+ install -Dm644 "${srcdir}/makepkg-cg.conf" "${pkgdir}/usr/share/makepkg-cg/makepkg-cg.conf"
+}