summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2016-03-21 07:06:23 +0900
committerQue Quotion2016-03-21 07:06:23 +0900
commite23a8fa281d0986b0e85569c9d3cb37c6c13e472 (patch)
treeec695876ff60f85249ada333187e2f398b9b2143
parenta1f4bfa438fa032d98b351ce608df9cec78ab351 (diff)
downloadaur-e23a8fa281d0986b0e85569c9d3cb37c6c13e472.tar.gz
Inconsistent behavior?
Some programs say the compiler is broken when using PGO or LTO, but really they just have a particular preference for how they are fed whitespace.
-rw-r--r--02.lto.patch12
-rw-r--r--03.pgo.patch10
-rw-r--r--04.graphite.patch4
3 files changed, 13 insertions, 13 deletions
diff --git a/02.lto.patch b/02.lto.patch
index f32711b58c17..056cad498c12 100644
--- a/02.lto.patch
+++ b/02.lto.patch
@@ -6,13 +6,13 @@
+ # Use lto if it is requested (check buildenv and PKGBUILD opts)
+ if check_buildoption "lto" "y" && [[ -f "$(gcc -print-search-dirs | grep install | awk '{print $2 "liblto_plugin.so"}')" ]]; then
-+ CFLAGS+="-flto=$(getconf _NPROCESSORS_ONLN)"
-+ CXXFLAGS+="-flto=$(getconf _NPROCESSORS_ONLN)"
-+ LDFLAGS+="-fuse-linker-plugin"
++ CFLAGS+=" -flto=$(getconf _NPROCESSORS_ONLN)"
++ CXXFLAGS+=" -flto=$(getconf _NPROCESSORS_ONLN)"
++ LDFLAGS+=" -fuse-linker-plugin"
+ LTOPLUGIN="$(gcc -print-search-dirs | grep install | awk '{print $2 "liblto_plugin.so"}')"
-+ ARFLAGS+="--plugin $LTOPLUGIN"
-+ RANLIBFLAGS+="--plugin $LTOPLUGIN"
-+ NMFLAGS+="--plugin $LTOPLUGIN"
++ ARFLAGS+=" --plugin $LTOPLUGIN"
++ RANLIBFLAGS+=" --plugin $LTOPLUGIN"
++ NMFLAGS+=" --plugin $LTOPLUGIN"
+ fi
+
run_function_safe "build"
diff --git a/03.pgo.patch b/03.pgo.patch
index 13543d0829b3..50e51153986c 100644
--- a/03.pgo.patch
+++ b/03.pgo.patch
@@ -8,13 +8,13 @@
+ if check_buildoption "pgo" "y"; then
+ if [ ! -d "$PROFDEST/$pkgbase.gen" ]; then
+ mkdir "$PROFDEST/$pkgbase.gen"
-+ CFLAGS+="-fprofile-generate -fprofile-dir=$PROFDEST/$pkgbase.gen"
-+ CXXFLAGS+="-fprofile-generate -fprofile-dir=$PROFDEST/$pkgbase.gen"
-+ LDFLAGS+="-lgcov"
++ CFLAGS+=" -fprofile-generate -fprofile-dir=$PROFDEST/$pkgbase.gen"
++ CXXFLAGS+=" -fprofile-generate -fprofile-dir=$PROFDEST/$pkgbase.gen"
++ LDFLAGS+=" -lgcov"
+ else
+ [[ ! -d "$PROFDEST/$pkgbase.used" ]] && mv "$PROFDEST/$pkgbase.gen" "$PROFDEST/$pkgbase.used"
-+ CFLAGS+="-fprofile-correction -fprofile-use -fprofile-dir=$PROFDEST/$pkgbase.used"
-+ CXXFLAGS+="-fprofile-correction -fprofile-use -fprofile-dir=$PROFDEST/$pkgbase.used"
++ CFLAGS+=" -fprofile-correction -fprofile-use -fprofile-dir=$PROFDEST/$pkgbase.used"
++ CXXFLAGS+=" -fprofile-correction -fprofile-use -fprofile-dir=$PROFDEST/$pkgbase.used"
+ fi
+ fi
+
diff --git a/04.graphite.patch b/04.graphite.patch
index 8742902737c2..ddb5a13eba28 100644
--- a/04.graphite.patch
+++ b/04.graphite.patch
@@ -6,8 +6,8 @@
+ # Utilize graphite if it is requested (check buildenv and PKGBUILD opts)
+ if check_buildoption "graphite" "y"; then
-+ CFLAGS+="-fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -ftree-vectorize"
-+ CXXFLAGS+="-fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -ftree-vectorize"
++ CFLAGS+=" -fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -ftree-vectorize"
++ CXXFLAGS+=" -fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -ftree-vectorize"
+ fi
run_function_safe "build"