summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2018-05-29 13:32:21 +0200
committerFrederik “Freso” S. Olesen2018-05-29 13:32:21 +0200
commit6d659ec6d47c1add33c5762ff13b04faa62cf5c3 (patch)
tree88a9cb6ffd5da2c975b8183163aaec0edb35e248
downloadaur-6d659ec6d47c1add33c5762ff13b04faa62cf5c3.tar.gz
Initial PKGBUILD
Aims to restore functionality that was removed with latest pacman. See also: https://git.archlinux.org/pacman.git/commit/?id=1a29744d0da8aa945b96b234574e0d5c80f13b62
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9eacf367a120
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = makepkg-tidy-scripts-git
+ pkgdesc = Collection of scripts for tidying packages created using makepkg. Includes optipng and upx support.
+ pkgver = 0.r7.4af5db2
+ pkgrel = 1
+ url = https://gitlab.com/Freso/makepkg-tidy-scripts
+ arch = any
+ license = GPL
+ makedepends = git
+ optdepends = optipng: For optipng tidy script.
+ optdepends = upx: For upx tidy script.
+ provides = makepkg-tidy-scripts
+ conflicts = makepkg-tidy-scripts
+ source = git+https://gitlab.com/Freso/makepkg-tidy-scripts
+ md5sums = SKIP
+
+pkgname = makepkg-tidy-scripts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68bb33a1079a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
+_pkgname=makepkg-tidy-scripts
+pkgname=${_pkgname}-git
+pkgver=0.r7.4af5db2
+pkgrel=1
+pkgdesc='Collection of scripts for tidying packages created using makepkg. Includes optipng and upx support.'
+arch=('any')
+url='https://gitlab.com/Freso/makepkg-tidy-scripts'
+license=('GPL')
+makedepends=('git')
+optdepends=(
+ 'optipng: For optipng tidy script.'
+ 'upx: For upx tidy script.'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm755 optipng.sh "$pkgdir"/usr/share/makepkg/tidy/optipng.sh
+ install -Dm755 upx.sh "$pkgdir"/usr/share/makepkg/tidy/upx.sh
+}