summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConor Randall2018-10-03 13:45:24 +0930
committerConor Randall2018-10-03 13:45:24 +0930
commit2a03a7b4ed3b7dae4f82a7b3e8fcadc0a7673035 (patch)
tree9e7b6cbe700da0972932a2c3b94a4364408b99ba
downloadaur-2a03a7b4ed3b7dae4f82a7b3e8fcadc0a7673035.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd4cfacc9ae9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = makeppkg-git
+ pkgdesc = wrapper for Arch Linux's makepkg, patches source before packages are built
+ pkgver = r42.a22848e
+ pkgrel = 1
+ url = https://github.com/ibrokemypie/makeppkg
+ arch = i686
+ arch = x86_64
+ license = Apache-2.0
+ makedepends = rust
+ makedepends = cargo
+ makedepends = gcc-libs
+ source = git+http://github.com/ibrokemypie/makeppkg/
+ sha256sums = SKIP
+
+pkgname = makeppkg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eaae452777a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: ibrokemypie <ibrokemypie@bastardi.net>
+pkgname=makeppkg-git
+_pkgname=makeppkg
+pkgver=r42.a22848e
+pkgrel=1
+makedepends=('rust' 'cargo' 'gcc-libs')
+arch=('i686' 'x86_64')
+pkgdesc="wrapper for Arch Linux's makepkg, patches source before packages are built"
+url="https://github.com/ibrokemypie/makeppkg"
+license=('Apache-2.0')
+source=('git+http://github.com/ibrokemypie/makeppkg/')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+}