summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-03-24 16:39:52 +0100
committerKlaus Alexander Seistrup2023-03-24 16:39:52 +0100
commit870991b317237c88f5233c79b3d31cfb4c7f10d8 (patch)
tree7fb27b97f8b62d88ea2b5b9fb5eb672ede50e86b
parent5222a3971ea15a1b112fb4f1ec9ff5e64eb89ff7 (diff)
downloadaur-870991b317237c88f5233c79b3d31cfb4c7f10d8.tar.gz
Move the gawk test to makesure.install
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
-rw-r--r--makesure.install26
3 files changed, 30 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aa99a2288ef..69858e775bed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = makesure
pkgdesc = Simple AWK-based task/command runner with declarative goals and dependencies
pkgver = 0.9.20
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/xonixx/makesure
+ install = makesure.install
arch = any
license = MIT
depends = awk
diff --git a/PKGBUILD b/PKGBUILD
index d143decf18ed..eddab4d698f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
pkgname='makesure'
pkgver=0.9.20
-pkgrel=3
+pkgrel=4
pkgdesc="Simple AWK-based task/command runner with declarative goals and dependencies"
arch=('any')
url='https://github.com/xonixx/makesure'
license=('MIT')
depends=('awk' 'sh')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+install="$pkgname.install"
package() {
cd "$pkgname-$pkgver"
@@ -20,25 +21,6 @@ package() {
install -Dm0644 README.md "$pkgdir/usr/share/docs/$pkgname/README.md"
}
-check() {
- command -v gawk >/dev/null 2>&1 && {
-
- cat <<EOF
-NB: makesure will use the installed gawk to provide awk.
-
-Gawk v5.2.1 is known to produce a warning like this:
-
- gawk: warning: The time extension is obsolete. Use the timex extension from gawkextlib instead.
-
-This annoyance that should go away with the next version of gawk.
-
-Please see https://github.com/xonixx/makesure/issues/118 for details.
-EOF
-
- }
- true
-}
-
sha256sums=(
'5dcb79e08c014134b6032f075685428c7d3e2b1e41d1f27fddcb5e85bd9badca'
)
diff --git a/makesure.install b/makesure.install
new file mode 100644
index 000000000000..b8de07b79442
--- /dev/null
+++ b/makesure.install
@@ -0,0 +1,26 @@
+# Install file for makesure@AUR (-*- sh -*-)
+
+post_install() {
+ command -v gawk >/dev/null 2>&1 && {
+
+ cat <<EOF
+NB: makesure will use the installed gawk to provide awk.
+
+Gawk v5.2.1 is known to produce a warning like this:
+
+ gawk: warning: The time extension is obsolete. Use the timex extension from gawkextlib instead.
+
+This annoyance that should go away with the next version of gawk.
+
+Please see https://github.com/xonixx/makesure/issues/118 for details.
+EOF
+
+ }
+ true
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+# eof