summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorokhsunrog2021-12-18 17:28:01 +0300
committerokhsunrog2021-12-18 17:28:01 +0300
commitb8b0acc9560d5263099d1e9fa729b486bd5a52e3 (patch)
treef88f87b8df113e3a95da14606f2f94280d04b0a6
downloadaur-b8b0acc9560d5263099d1e9fa729b486bd5a52e3.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--0001-Fix-DBus-service.patch7
-rw-r--r--PKGBUILD55
-rw-r--r--mako.service15
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3552d619c40e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = mako-no-blur-git
+ pkgdesc = Lightweight notification daemon for Wayland with HiDPI patches.
+ pkgver = v1.6.r10.gfe7f494
+ pkgrel = 1
+ url = http://mako-project.org
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = scdoc
+ makedepends = systemd
+ makedepends = wayland-protocols
+ makedepends = git
+ depends = gdk-pixbuf2
+ depends = pango
+ depends = cairo
+ depends = systemd-libs
+ depends = wayland
+ optdepends = jq: support for 'makoctl menu'
+ provides = mako
+ provides = mako-git
+ conflicts = mako
+ conflicts = mako-git
+ source = mako::git+https://github.com/lilydjwg/mako.git
+ source = mako.service
+ source = 0001-Fix-DBus-service.patch
+ sha1sums = SKIP
+ sha1sums = 688484d6bf677e6f6014c9311ff40fabae748bcc
+ sha1sums = 64b8a3446fa1ddc3d876629a0c4a3d1d6bb0b20f
+
+pkgname = mako-no-blur-git
diff --git a/0001-Fix-DBus-service.patch b/0001-Fix-DBus-service.patch
new file mode 100644
index 000000000000..aa007cc10d37
--- /dev/null
+++ b/0001-Fix-DBus-service.patch
@@ -0,0 +1,7 @@
+--- a/fr.emersion.mako.service.in
++++ b/fr.emersion.mako.service.in
+@@ -1,3 +1,4 @@
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=@bindir@/mako
++SystemdService=mako.service
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04e7931b222e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+ # Maintainer: okhsunrog <me@gornushko.com>
+
+pkgname=mako-no-blur-git
+_pkgname=mako
+pkgver=v1.6.r10.gfe7f494
+pkgrel=1
+license=('MIT')
+pkgdesc='Lightweight notification daemon for Wayland with HiDPI patches.'
+makedepends=("meson" "scdoc" "systemd" "wayland-protocols" "git")
+depends=(
+ "gdk-pixbuf2"
+ "pango"
+ "cairo"
+ "systemd-libs"
+ "wayland"
+)
+optdepends=("jq: support for 'makoctl menu'")
+arch=("x86_64")
+url='http://mako-project.org'
+source=(
+ "mako::git+https://github.com/lilydjwg/mako.git"
+ "mako.service"
+ "0001-Fix-DBus-service.patch"
+)
+sha1sums=('SKIP'
+ '688484d6bf677e6f6014c9311ff40fabae748bcc'
+ '64b8a3446fa1ddc3d876629a0c4a3d1d6bb0b20f')
+provides=('mako' 'mako-git')
+conflicts=('mako' 'mako-git')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long 2> /dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ patch -Np1 -i "$srcdir/0001-Fix-DBus-service.patch" -d "$_pkgname"
+}
+
+build() {
+ cd "$_pkgname"
+ arch-meson -Dzsh-completions=true -Dsd-bus-provider=libsystemd build
+ ninja -C build
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir/" ninja -C build install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-*}"/LICENSE
+ install -Dm0644 ../mako.service -t "$pkgdir"/usr/lib/systemd/user/
+}
diff --git a/mako.service b/mako.service
new file mode 100644
index 000000000000..1c48492d9629
--- /dev/null
+++ b/mako.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Lightweight Wayland notification daemon
+Documentation=man:mako(1)
+PartOf=graphical-session.target
+After=graphical-session.target
+ConditionEnvironment=WAYLAND_DISPLAY
+
+[Service]
+Type=dbus
+BusName=org.freedesktop.Notifications
+ExecStart=/usr/bin/mako
+ExecReload=/usr/bin/makoctl reload
+
+[Install]
+WantedBy=graphical-session.target