summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2023-04-16 11:26:47 +0200
committerAlphaJack2023-04-16 11:26:49 +0200
commitbaddf9ab507c6e16c7dc335da3cdfd318f0274a7 (patch)
tree17f71ce048908143ec01201b21007ab8596f0281
parent65adf0f1aff6dc7eb29b9f0f63a033d9389a68af (diff)
downloadaur-baddf9ab507c6e16c7dc335da3cdfd318f0274a7.tar.gz
Updated maldet to 1.6.5, added systemd units to update signatures
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rw-r--r--maldet-update-signatures.service10
-rw-r--r--maldet-update-signatures.timer10
-rw-r--r--maldet.install7
5 files changed, 45 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8bda4ab1130..1cdc9d853fa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = maldet
pkgdesc = Linux malware scanner designed around threats faced in shared host environments
- pkgver = 1.6.4
- pkgrel = 9
+ pkgver = 1.6.5
+ pkgrel = 1
url = https://www.rfxn.com/projects/linux-malware-detect/
install = maldet.install
arch = any
@@ -9,6 +9,7 @@ pkgbase = maldet
depends = inetutils
depends = inotify-tools
depends = perl
+ depends = systemd
provides = linux-malware-detect
backup = etc/maldet/hookscan.conf
backup = etc/maldet/ignore_file_ext
@@ -18,7 +19,11 @@ pkgbase = maldet
backup = etc/maldet/internals.conf
backup = etc/maldet/maldet.conf
backup = etc/maldet/monitor_paths
- source = https://github.com/rfxn/linux-malware-detect/archive/1.6.4.tar.gz
- sha256sums = 3ad66eebd443d32dd6c811dcf2d264b78678c75ed1d40c15434180d4453e60d2
+ source = https://github.com/rfxn/linux-malware-detect/archive/1.6.5.tar.gz
+ source = maldet-update-signatures.service
+ source = maldet-update-signatures.timer
+ sha256sums = 23c7cf5649b0f1c1d4e2ab78961eb58453ed01aeffb53926fde6f2baa7f61e68
+ sha256sums = 172486c33905df4032d74dd7f79c6dafce64df2006a037fba3c6aded99eaaba1
+ sha256sums = 0d6d61dadb72eec8ded0d7e97d4b723fd2e4323e68852add59d372ef3f4e7b00
pkgname = maldet
diff --git a/PKGBUILD b/PKGBUILD
index cb7723fc741a..56ff540a46c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
# Contributor: Sergey Mamonov <mrqwer88@gmail.com>
pkgname="maldet"
-pkgver=1.6.4
-pkgrel=9
+pkgver=1.6.5
+pkgrel=1
pkgdesc="Linux malware scanner designed around threats faced in shared host environments"
url="https://www.rfxn.com/projects/linux-malware-detect/"
license=("GPL2")
arch=("any")
provides=("linux-malware-detect")
-depends=("inetutils" "inotify-tools" "perl")
-depends_x86_64=("lib32-glibc")
-source=("https://github.com/rfxn/linux-malware-detect/archive/$pkgver.tar.gz")
+depends=("inetutils" "inotify-tools" "perl" "systemd")
+source=("https://github.com/rfxn/linux-malware-detect/archive/$pkgver.tar.gz"
+ "maldet-update-signatures.service"
+ "maldet-update-signatures.timer")
backup=("etc/maldet/hookscan.conf"
"etc/maldet/ignore_file_ext"
"etc/maldet/ignore_inotify"
@@ -24,7 +25,9 @@ backup=("etc/maldet/hookscan.conf"
"etc/maldet/maldet.conf"
"etc/maldet/monitor_paths"
)
-sha256sums=('3ad66eebd443d32dd6c811dcf2d264b78678c75ed1d40c15434180d4453e60d2')
+sha256sums=('23c7cf5649b0f1c1d4e2ab78961eb58453ed01aeffb53926fde6f2baa7f61e68'
+ '172486c33905df4032d74dd7f79c6dafce64df2006a037fba3c6aded99eaaba1'
+ '0d6d61dadb72eec8ded0d7e97d4b723fd2e4323e68852add59d372ef3f4e7b00')
install="maldet.install"
prepare(){
@@ -105,6 +108,8 @@ package(){
cp -ar "files/"* "$pkgdir/usr/share/maldet"
# systemd files
install -D -m 644 "files/service/maldet.service" "$pkgdir/usr/lib/systemd/system/maldet.service"
+ install -D -m 644 "$srcdir/maldet-update-signatures.service" "$pkgdir/usr/lib/systemd/system/maldet-update-signatures.service"
+ install -D -m 644 "$srcdir/maldet-update-signatures.timer" "$pkgdir/usr/lib/systemd/system/maldet-update-signatures.timer"
# program data
install -d "$pkgdir/var/lib/maldet/"{internals,quarantine,sess,sigs,clean,tmp,pub}
install -d "$pkgdir/var/log/maldet"
diff --git a/maldet-update-signatures.service b/maldet-update-signatures.service
new file mode 100644
index 000000000000..95ba06fd2b91
--- /dev/null
+++ b/maldet-update-signatures.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Linux Malware Detect signature update service - maldet
+After=network-online.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/maldet --update-sigs
+
+[Install]
+WantedBy=multi-user.target
diff --git a/maldet-update-signatures.timer b/maldet-update-signatures.timer
new file mode 100644
index 000000000000..1128c2de9c69
--- /dev/null
+++ b/maldet-update-signatures.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=Linux Malware Detect signature update timer - maldet
+
+[Timer]
+OnCalendar=daily
+RandomizedDelaySec=360
+Persistent=true
+
+[Install]
+WantedBy=timers.target
diff --git a/maldet.install b/maldet.install
index 95bbc8d6c21c..e04cf097c794 100644
--- a/maldet.install
+++ b/maldet.install
@@ -1,9 +1,12 @@
post_install(){
cat <<INFO
-Before running maldet, you will need to update signature files as root by running
+You are strongly advised to update signature version by executing this command:
- maldet -u
+ systemctl enable --now maldet-update-signatures.timer
+ systemctl start maldet-update-signatures.service
+
+Signatures must be updated at least once before running maldet.
INFO
}