summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex2023-06-20 23:50:50 +0200
committerAlex2023-06-20 23:50:50 +0200
commitd114a92c4f6677b8cfbe17f91d271d348491d532 (patch)
tree09e658c503472b00ced12ee90bed568ed46bad09
downloadaur-d114a92c4f6677b8cfbe17f91d271d348491d532.tar.gz
Add Malt
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--gen.desktop10
-rw-r--r--gen.pngbin0 -> 10202 bytes
-rw-r--r--no-scrollbar.css5
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e596afa94999
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = malt
+ pkgdesc = A native desktop application for easy access to Malt, the online freelance and professional assignment platform.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.malt.com/
+ arch = x86_64
+ license = GNU AGPL
+ makedepends = nodejs
+ makedepends = nodejs-nativefier
+ makedepends = npm
+ provides = malt
+ conflicts = malt
+ source = gen.png
+ source = gen.desktop
+ source = no-scrollbar.css
+ sha256sums = 378a556cbdd699efe1031970cbff94c4ea5f7edca4af76b0374acfaf3430a1e5
+ sha256sums = 7e9db082baae45b560e7e8cf9d8ba176f80c93487e6fcc9eb7c227fef007ea81
+ sha256sums = 1474a74c47dfeb879d4a2538b3b24bfdca75be878fbe1c04fd82fba2e112f381
+
+pkgname = malt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64e56e3f7b1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Alexis Potelle <alexispotelle at gmail dot com>
+
+_instname=malt
+pkgname=malt
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A native desktop application for easy access to Malt, the online freelance and professional assignment platform."
+arch=('x86_64')
+url=https://www.malt.com/
+license=('GNU AGPL')
+groups=()
+depends=()
+makedepends=(nodejs nodejs-nativefier npm)
+provides=($pkgname)
+conflicts=($pkgname)
+replaces=()
+backup=()
+options=()
+install=
+source=("gen.png"
+ "gen.desktop"
+ "no-scrollbar.css")
+sha256sums=('378a556cbdd699efe1031970cbff94c4ea5f7edca4af76b0374acfaf3430a1e5'
+ '7e9db082baae45b560e7e8cf9d8ba176f80c93487e6fcc9eb7c227fef007ea81'
+ '1474a74c47dfeb879d4a2538b3b24bfdca75be878fbe1c04fd82fba2e112f381')
+
+
+build() {
+ nativefier $url \
+ --icon gen.png \
+ --name $_instname \
+ --user-agent "Mozilla/5.0 (X11; Linux ${CARCH};) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.5735.133 Safari/537.36"\
+ --inject no-scrollbar.css\
+ --internal-urls "(.*?malt\..*?)" \
+ --single-instance \
+ --tray
+
+
+}
+
+package() {
+ install -d "$pkgdir"/opt "$pkgdir"/usr/{bin,share/pixmaps}
+ install -Dm644 gen.desktop "$pkgdir"/usr/share/applications/$_instname.desktop
+
+ cp -rL $_instname-linux-* "$pkgdir"/opt/$pkgname
+ ln -sf /opt/$pkgname/$_instname "$pkgdir"/usr/bin/$_instname
+ cp $srcdir/gen.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+
+ chmod 666 "$pkgdir"/opt/$pkgname/resources/app/nativefier.json
+}
+
diff --git a/gen.desktop b/gen.desktop
new file mode 100644
index 000000000000..21c01b945365
--- /dev/null
+++ b/gen.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=Malt
+Comment=Freelancing and professional networking platform
+Exec=malt
+Icon=malt
+Terminal=false
+Categories=Development;WebDevelopment;Business;Jobs;
+Keywords=freelance;missions;work;platform;professional;networking
+
diff --git a/gen.png b/gen.png
new file mode 100644
index 000000000000..a76d5664cd4d
--- /dev/null
+++ b/gen.png
Binary files differ
diff --git a/no-scrollbar.css b/no-scrollbar.css
new file mode 100644
index 000000000000..20fd9653444f
--- /dev/null
+++ b/no-scrollbar.css
@@ -0,0 +1,5 @@
+::-webkit-scrollbar {
+ display: none;
+}
+
+ \ No newline at end of file