summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-09-02 16:23:49 +0200
committerKr1ss2020-09-02 16:23:49 +0200
commit9fcd5f8295529717aa1d56e25acbe95a056a232a (patch)
tree97a5962ace16860a5e60e5007dd10489b85fe5e8
parent152b27f1e2c68213516a53577352c94e66ec107d (diff)
downloadaur-9fcd5f8295529717aa1d56e25acbe95a056a232a.tar.gz
update: maltego 4.2.12.13389-1
upstream release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD52
-rw-r--r--changelog5
-rw-r--r--maltego.install12
4 files changed, 34 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 380bd2331b91..8b2e5db8b551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = maltego
- pkgdesc = Maltego information gathering software by Paterva
- pkgver = 4.2.11.13104
+ pkgdesc = Information gathering software by Paterva
+ pkgver = 4.2.12.13389
pkgrel = 1
- url = https://maltego-downloads.s3.us-east-2.amazonaws.com/linux
+ url = https://www.maltego.com
install = maltego.install
+ changelog = changelog
arch = i686
arch = x86_64
- license = Commercial
- depends = java-runtime=8
- source_i686 = https://maltego-downloads.s3.us-east-2.amazonaws.com/linux/Maltego.v4.2.11.13104.deb
- md5sums_i686 = ce45a73d7745b97fc86de33b5f74e68f
- sha256sums_i686 = 1b73b0e77add946dde39c726898be7b217afeec9f6b7b014bf28f8971a7cf3ab
- source_x86_64 = https://maltego-downloads.s3.us-east-2.amazonaws.com/linux/Maltego.v4.2.11.13104.deb
- md5sums_x86_64 = ce45a73d7745b97fc86de33b5f74e68f
- sha256sums_x86_64 = 1b73b0e77add946dde39c726898be7b217afeec9f6b7b014bf28f8971a7cf3ab
+ license = custom
+ depends = java-runtime
+ source = https://maltego-downloads.s3.us-east-2.amazonaws.com/linux/Maltego.v4.2.12.13389.deb
+ sha256sums = 1a0d7ff2ca7d9d370521d047ff9fafbffe12f0d3ce5bd57264d64a2f719855ef
pkgname = maltego
diff --git a/PKGBUILD b/PKGBUILD
index f17f3713300f..5a39cab28324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,30 @@
-# Maintainer: Stephen Argent <steve [at] tuxcon [dot] com>
+# Maintainer : Kr1ss $(sed s/\+/./g\;s/\-/@/ <<< \<kr1ss+x-yandex+com\>)
+# Contributor : Stephen Argent <steve [at] tuxcon [dot] com>
+
pkgname=maltego
-pkgdesc='Maltego information gathering software by Paterva'
-license=('Commercial')
-url='https://maltego-downloads.s3.us-east-2.amazonaws.com/linux'
-pkgver=4.2.11.13104
+
+pkgver=4.2.12.13389
pkgrel=1
-package=Maltego.v${pkgver}.deb
+
+pkgdesc='Information gathering software by Paterva'
+url="https://www.$pkgname.com"
arch=('i686' 'x86_64')
-depends=('java-runtime=8')
+license=('custom')
-source_i686=(
- "${url}/${package}"
-)
-source_x86_64=(
- "${url}/${package}"
-)
-sha256sums_i686=(1b73b0e77add946dde39c726898be7b217afeec9f6b7b014bf28f8971a7cf3ab)
-sha256sums_x86_64=(1b73b0e77add946dde39c726898be7b217afeec9f6b7b014bf28f8971a7cf3ab)
-md5sums_i686=(ce45a73d7745b97fc86de33b5f74e68f)
-md5sums_x86_64=(ce45a73d7745b97fc86de33b5f74e68f)
+depends=('java-runtime')
+
+install="$pkgname.install"
+changelog=changelog
+source=("https://$pkgname-downloads.s3.us-east-2.amazonaws.com/linux/Maltego.v$pkgver.deb")
+sha256sums=('1a0d7ff2ca7d9d370521d047ff9fafbffe12f0d3ce5bd57264d64a2f719855ef')
-install=maltego.install
package() {
- if [ "$CARCH" = "i686" ] ; then
- deb_arch="i386"
- elif [ "$CARCH" = "x86_64" ] ; then
- deb_arch="amd64"
- else
- echo "Unknown arch: $CARCH"
- exit 1
- fi
-
- cd "$srcdir"
- #deb_package="MaltegoCE.v${pkgver}.deb"
- ar xf "$package"
- tar xf data.tar.gz -C "$pkgdir"
- # Packagaers left DS_Store files, so we have to remove
+ bsdtar xf data.tar.gz -C "$pkgdir"
+ # Packagers left DS_Store files, so we have to remove
rm -rf "$pkgdir"/{,usr/{,share/{,maltego/}}}.DS_Store
- #rm -rf $pkgdir/.DS_Store
}
+
+# vim: ts=2 sw=2 et ft=PKGBUILD:
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..bb942cc2adf8
--- /dev/null
+++ b/changelog
@@ -0,0 +1,5 @@
+maltego (4.2.12) whatever; urgency=medium
+
+ * Package created with FPM.
+
+ -- Maltego <support@maltego.com> Thu, 13 Aug 2020 01:33:55 -0700
diff --git a/maltego.install b/maltego.install
index 81ab527131e5..4ee4520e4d46 100644
--- a/maltego.install
+++ b/maltego.install
@@ -1,6 +1,6 @@
post_install() {
echo ""
- echo "[+] run '/sbin/maltego' to run the application (if nothing works, check 'java' is in your \$PATH)"
+ echo "[+] run '/usr/bin/maltego' to run the application (if nothing works, check 'java' is in your \$PATH)"
echo ">>> documentation resides @ 'https://www.paterva.com/web7/docs.php'"
echo ""
echo ">>> this application isn't functional until you obtain a Maltego Community Edition activation code and account"
@@ -11,13 +11,5 @@ post_install() {
}
post_upgrade() {
- echo ""
- echo "[+] run '/sbin/maltego' to run the application (if nothing works, check 'java' is in your \$PATH)"
- echo ">>> documentation resides @ 'https://www.paterva.com/web7/docs.php'"
- echo ""
- echo ">>> this application isn't functional until you obtain a Maltego Community Edition activation code and account"
- echo ">>> REGISTER a FREE ACCOUNT for Maltego Community Editon @ 'https://www.paterva.com/web7/community/community.php'"
- echo ""
- echo ">>> this has been tested to work with jre8-openjdk"
- echo ""
+ post_install "$@"
}