summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsta Zahn2021-02-24 18:13:13 -0500
committerIsta Zahn2021-02-24 18:13:13 -0500
commit6b23977a0c2b225ed455148185934b9950a36802 (patch)
treed9f88c0e9696a95d7f9486209cfe18b1a0dd2101
downloadaur-6b23977a0c2b225ed455148185934b9950a36802.tar.gz
mambaforge!
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rw-r--r--mambaforge.install12
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..489e13f0385e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mambaforge
+ pkgdesc = Conda and Mamba package managers configured to use conda-forge.
+ pkgver = 4.9.2
+ pkgrel = 2
+ url = https://github.com/conda-forge/miniforge
+ install = mambaforge.install
+ arch = x86_64
+ license = BSD-3-Clause
+ options = !strip
+ options = libtool
+ options = staticlibs
+ source = Mambaforge-4.9.2.sh::https://github.com/conda-forge/miniforge/releases/download/4.9.2-7/Mambaforge-4.9.2-7-Linux-x86_64.sh
+ source = mambaforge.install
+ sha256sums = 5a827a62d98ba2217796a9dc7673380257ed7c161017565fba8ce785fb21a599
+ sha256sums = 1df814280df859c40cd7dd1f7ff2552ca72dfbf9cde083f52e55c557b93d8977
+
+pkgname = mambaforge
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51f58dd927a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer : Ista Zahn <istazahn@gmail.com>
+## Based on miniconda3 aur package by Ashwin Vishn Immae, Martin Wimpress and Jingbei Li
+pkgname=mambaforge
+pkgver=4.9.2
+pkgrel=2
+pkgdesc="Conda and Mamba package managers configured to use conda-forge."
+arch=('x86_64')
+url="https://github.com/conda-forge/miniforge"
+license=("BSD-3-Clause")
+source=("Mambaforge-${pkgver}.sh::https://github.com/conda-forge/miniforge/releases/download/${pkgver}-7/Mambaforge-${pkgver}-7-Linux-x86_64.sh"
+ "$pkgname.install")
+options=(!strip libtool staticlibs)
+sha256sums=('5a827a62d98ba2217796a9dc7673380257ed7c161017565fba8ce785fb21a599'
+ '1df814280df859c40cd7dd1f7ff2552ca72dfbf9cde083f52e55c557b93d8977')
+install="$pkgname.install"
+
+package() {
+ prefix="${pkgdir}/opt/${pkgname}"
+ LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
+
+ msg2 "Packaging ${pkgname} for installation to /opt/${pkgname}"
+ bash "${srcdir}/Mambaforge-${pkgver}.sh" -b -p $prefix -f
+ [ "$BREAK_EARLY" = 1 ] && exit 1
+ cd "${prefix}"
+
+ msg2 "Correcting permissions"
+ chmod a+r -R pkgs
+
+ msg2 "Stripping \$pkgdir"
+ sed "s|${pkgdir}||g" -i $(grep "$pkgdir" . -rIl)
+
+ msg2 "Installing license"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/mambaforge.install b/mambaforge.install
new file mode 100644
index 000000000000..8ec95fdb9a2e
--- /dev/null
+++ b/mambaforge.install
@@ -0,0 +1,12 @@
+post_install(){
+ echo -e '
+If your shell is Bash or a Bourne variant, enable conda for the current user with
+
+ $ echo "[ -f /opt/mambaforge/etc/profile.d/conda.sh ] && source /opt/mambaforge/etc/profile.d/conda.sh" >> ~/.bashrc
+
+or, for all users, enable conda with
+
+ $ sudo ln -s /opt/mambaforge/etc/profile.d/conda.sh /etc/profile.d/conda.sh
+'
+}
+