summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-02-04 01:22:38 +0000
committerDaniel Bermond2020-02-04 01:22:38 +0000
commit2990a31da3e4ca159984db345573b5ea730cf0b6 (patch)
tree7befe3fe1155b4f7a38cac4d529baf92428618c9
parentc9f747551e5b8a1425b2b647afd800894cf6ed37 (diff)
downloadaur-2990a31da3e4ca159984db345573b5ea730cf0b6.tar.gz
Add desktop file and icon. Add flac to depends.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
-rw-r--r--mame.desktop20
-rw-r--r--mame.svg5
4 files changed, 44 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87bef5c8302c..727fa529b206 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mame-git
pkgdesc = A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support (git version)
- pkgver = 0.210.r80.g0660656754b
+ pkgver = 0.218.r0.g0e2a252d309
pkgrel = 1
url = https://www.mamedev.org/
arch = x86_64
@@ -19,12 +19,17 @@ pkgbase = mame-git
depends = pugixml
depends = portmidi
depends = portaudio
+ depends = flac
provides = mame
conflicts = mame
source = git+https://github.com/mamedev/mame.git
source = mame.sh
+ source = mame.desktop
+ source = mame.svg
sha256sums = SKIP
sha256sums = ee1c59bafc5e5441e99fa4c58108a3e18048e60672f34de865c8a5a976094dba
+ sha256sums = 6beb883c8efed5b7466d43d0658b47c3e4a9928b5d0245ed56446b230e28306b
+ sha256sums = 17c442c933d764175e4ce1de50a80c0c2ddd5d733caf09c3cd5e6ba697ac43f4
pkgname = mame-git
diff --git a/PKGBUILD b/PKGBUILD
index c0e5d98bad0d..534b709f6013 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=mame-git
_srcname=mame
-pkgver=0.210.r80.g0660656754b
+pkgver=0.218.r0.g0e2a252d309
pkgrel=1
pkgdesc='A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support (git version)'
url='https://www.mamedev.org/'
license=('GPL')
arch=('x86_64')
-depends=('sdl2_ttf' 'qt5-base' 'lua' 'libutf8proc' 'pugixml' 'portmidi' 'portaudio')
+depends=('sdl2_ttf' 'qt5-base' 'lua' 'libutf8proc' 'pugixml' 'portmidi' 'portaudio' 'flac')
makedepends=('git' 'nasm' 'python' 'asio' 'rapidjson' 'glm' 'libxinerama')
provides=('mame')
conflicts=('mame')
source=('git+https://github.com/mamedev/mame.git'
- 'mame.sh')
+ 'mame.sh'
+ 'mame.desktop'
+ 'mame.svg')
sha256sums=('SKIP'
- 'ee1c59bafc5e5441e99fa4c58108a3e18048e60672f34de865c8a5a976094dba')
+ 'ee1c59bafc5e5441e99fa4c58108a3e18048e60672f34de865c8a5a976094dba'
+ '6beb883c8efed5b7466d43d0658b47c3e4a9928b5d0245ed56446b230e28306b'
+ '17c442c933d764175e4ce1de50a80c0c2ddd5d733caf09c3cd5e6ba697ac43f4')
prepare() {
cd "$_srcname"
@@ -61,6 +65,10 @@ package() {
install -D -m644 src/osd/modules/opengl/shader/glsl*.*h -t "${pkgdir}/usr/lib/mame/shader/"
cp -a {artwork,bgfx,plugins,language,ctrlr,keymaps,hash} "${pkgdir}/usr/lib/mame/"
+ # desktop file and icon
+ install -D -m644 "${srcdir}/mame.desktop" -t "${pkgdir}/usr/share/applications"
+ install -D -m644 "${srcdir}/mame.svg" -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+
# documentation
install -d -m0755 "${pkgdir}/usr/share/doc"
cp -a docs "${pkgdir}/usr/share/doc/mame"
diff --git a/mame.desktop b/mame.desktop
new file mode 100644
index 000000000000..072ec470eafc
--- /dev/null
+++ b/mame.desktop
@@ -0,0 +1,20 @@
+[Desktop Entry]
+Name=MAME™ Arcade Emulator
+Name[ca]=Emulador de jocs arcade MAME™
+Name[fr]=Emulateur arcade MAME™
+Name[it]=Emulatore di giochi arcade MAME™
+GenericName=Arcade Emulator
+GenericName[ca]=Emulador de jocs arcade
+GenericName[fr]=Emulateur arcade
+GenericName[it]=Emulatore di giochi arcade
+Comment=Play vintage arcade games using the MAME™ emulator
+Comment[ca]=Jugueu a jocs d'arcade antics emprant l'emulador MAME™
+Comment[fr]=Jugueu a jocs d'arcade antics emprant l'emulador MAME™
+Comment[it]=Gioca ai vecchi arcade con l'emulatore MAME™
+Exec=/usr/bin/mame
+Icon=mame
+Terminal=false
+Type=Application
+Categories=Game;Emulator;
+Keywords=Game;Emulator;Arcade;
+
diff --git a/mame.svg b/mame.svg
new file mode 100644
index 000000000000..9e1281728366
--- /dev/null
+++ b/mame.svg
@@ -0,0 +1,5 @@
+<svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" version="1.1" viewBox="0 0 32 32">
+ <path style="opacity:0.2;fill-rule:evenodd" d="M 21,7 1.9999996,26 H 10 l 8,-8 v 8 l 8,-8 v 8 l 4,-4 V 7.1 L 21,17 Z"/>
+ <path style="fill:#2b87d8;fill-rule:evenodd" d="M 21,6 2,25 h 8 l 8,-8 v 8 l 8,-8 v 8 l 4,-4 V 7 l -9,9 z"/>
+ <path style="opacity:0.2;fill:#ffffff;fill-rule:evenodd" d="M 21,6 2,25 H 3 L 21,7 Z m 9,1 -9,9 v 1 l 9,-9 z"/>
+</svg>