summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTakuro Onoue2021-11-26 15:19:48 +0900
committerTakuro Onoue2021-11-26 15:19:48 +0900
commit00318f97c9137987ae50096908a67f7db85dc27d (patch)
tree0f2e35c20e96307c087fd9b39b8ee00f49913b12
downloadaur-00318f97c9137987ae50096908a67f7db85dc27d.tar.gz
initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b17f03d906af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = man-pages-postgresql-ja
+ pkgdesc = Japanese man pages for PostgreSQL
+ pkgver = 13.1
+ pkgrel = 1
+ url = https://pgsql-jp.github.io/
+ arch = any
+ license = custom
+ source = https://pgsql-jp.github.io/jpug-doc/13.1/man.tar.gz
+ md5sums = 750262cc83a6af19aeb9b344b7bc1ce5
+
+pkgname = man-pages-postgresql-ja
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5f704c0184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: kusanaginoturugi <kusanaginoturugi at gmail dot com>
+pkgname=man-pages-postgresql-ja
+pkgver=13.1
+pkgrel=1
+pkgdesc="Japanese man pages for PostgreSQL"
+arch=("any")
+url="https://pgsql-jp.github.io/"
+license=("custom")
+source=("${url}jpug-doc/${pkgver}/man.tar.gz")
+md5sums=('750262cc83a6af19aeb9b344b7bc1ce5')
+
+package() {
+ _license_url="https://www.postgresql.jp/document/13/html/legalnotice.html"
+ _destdir="${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "${_destdir}"
+ curl -Ls "${_license_url}" -o "${_destdir}/legalnotice.html"
+
+ cd ${srcdir}
+ for i in 1 3 7; do
+ if [ ! -e "${pkgdir}/usr/share/man/ja/man${i}/" ]; then
+ install -d "${pkgdir}/usr/share/man/ja/man${i}/"
+
+ # To copy a noexistent man only.
+ for f in man${i}/*.${i} ; do
+ if [ ! -e "/usr/share/man/ja/${f}" ]; then
+ install -D -m644 ${f} "${pkgdir}/usr/share/man/ja/${f}"
+ fi
+ done
+ fi
+ done
+}