summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2019-06-13 16:44:02 -0400
committerjgmdev2019-06-13 16:44:02 -0400
commitb5529e69e05d5f374310cc83b1fdf4acbca966da (patch)
tree759b6c0e763b3047308091894eda9be6bbbe3af0
parent1337c07134322a8205d9001030490fd40dd9ddf1 (diff)
downloadaur-b5529e69e05d5f374310cc83b1fdf4acbca966da.tar.gz
Fixed issue due to manager website changes.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91b88076e5d8..4cc756d8b6d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = manager-accounting
pkgdesc = Manager is free accounting software for small business
- pkgver = 19.5.14
+ pkgver = 19.6.27
pkgrel = 1
url = http://www.manager.io/
install = manager-accounting.install
@@ -12,7 +12,7 @@ pkgbase = manager-accounting
depends = gtk-sharp-3
options = !makeflags
source = LICENSE
- source = https://d2ap5zrlkavzl7.cloudfront.net/19.5.14/Manager.deb
+ source = https://d2ap5zrlkavzl7.cloudfront.net/19.6.27/Manager.deb
sha256sums = bd144763506372341487683b0f28ad627e7e8923ea8ef8569541b55f4b987061
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 35ea421f95c7..4051468f7639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: François M. <francois5537 @ gmail.com>
## Dynamically retrieve the download url
-_manager_source=$(wget -o /dev/null http://www.manager.io/desktop/download/ubuntu/ -O - \
- | grep -o -P 'https://.*Manager\.deb' | tail -n1
+_manager_source=$(wget -o /dev/null http://www.manager.io/download/latest/Manager.deb -O - \
+ | grep -o -P 'https://[a-zA-Z0-9]+\.cloudfront\.net/[0-9]+\.[0-9]+\.[0-9]+/Manager\.deb' \
+ | tail -n1
)
pkgname=manager-accounting
pkgver=$(echo "${_manager_source}" \