summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2018-12-10 12:28:24 -0400
committerjgmdev2018-12-10 12:28:24 -0400
commitb942e6f88fb16b111f7dc2c5b6c6d00ea3997609 (patch)
treeb15cd5cb77a291e14eaad5c525775b7155b625e3
parent64d51faf99f58461c28cafe9c9a070c0b4112a56 (diff)
downloadaur-b942e6f88fb16b111f7dc2c5b6c6d00ea3997609.tar.gz
Dynamically get the manager-accounting source url from the download page.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1f9d99e32b9..c0935b988efa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 20 03:01:00 UTC 2018
+# Mon Dec 10 16:26:55 UTC 2018
pkgbase = manager-accounting
pkgdesc = Manager is free accounting software for small business
- pkgver = 18.10.76
+ pkgver = 18.11.66
pkgrel = 1
url = http://www.manager.io/
install = manager-accounting.install
@@ -16,7 +16,7 @@ pkgbase = manager-accounting
depends = gtk-sharp-3
options = !makeflags
source = LICENSE
- source = https://mngr.s3.amazonaws.com/18.10.76/manager-accounting.zip
+ source = https://d2ap5zrlkavzl7.cloudfront.net/18.11.66/manager-accounting.zip
source = https://raw.githubusercontent.com/ericsink/SQLitePCL.raw/02ae6a75ba254fe1f6bf27495545b5eac79456ac/sqlite3/sqlite3.c
sha256sums = bd144763506372341487683b0f28ad627e7e8923ea8ef8569541b55f4b987061
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 24b9dc304db4..4267816f9296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,15 @@
# Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
# Contributor: François M. <francois5537 @ gmail.com>
+## Dynamically retrieve the download url
+_manager_source=$(wget -o /dev/null http://www.manager.io/desktop/download/ -O - \
+ | grep -o -P 'https://.*manager-accounting\.zip'
+)
+
pkgname=manager-accounting
-pkgver=`wget -o /dev/null http://www.manager.io/desktop/download/ -O - \
- | grep -o -P 'https://.*\.zip' \
- | grep -o -P '[0-9]+\.[0-9]+\.[0-9]+' \
- | head -1`
+pkgver=$(echo "${_manager_source}" \
+ | grep -o -P '[0-9]+\.[0-9]+\.[0-9]+'
+)
pkgrel=1
pkgdesc='Manager is free accounting software for small business'
arch=('i686' 'x86_64')
@@ -17,7 +21,7 @@ install=manager-accounting.install
options=('!makeflags')
source=(
"LICENSE"
- "https://mngr.s3.amazonaws.com/${pkgver}/manager-accounting.zip"
+ "${_manager_source}"
"https://raw.githubusercontent.com/ericsink/SQLitePCL.raw/02ae6a75ba254fe1f6bf27495545b5eac79456ac/sqlite3/sqlite3.c"
)
sha256sums=(