summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadotsuki2015-08-03 19:57:20 -0500
committermadotsuki2015-08-03 19:57:20 -0500
commitdde1f290c1ab179f78e3691f03debd24575b77bf (patch)
tree45ff5ee44785fa37df6dff1a99389c9e3d3f8a1f
downloadaur-dde1f290c1ab179f78e3691f03debd24575b77bf.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deb350d6db9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mandelbulber2
+ pkgdesc = 3D application designed to render 3D fractals such as the Mandelbulb, Mandelbox, BulbBox, JuliaBulb, Menger Sponge, and Iterated Function Systems. Rewritten from scratch with new Qt based interface.
+ pkgver = 2.04
+ pkgrel = 1
+ url = http://www.mandelbulber.com/
+ arch = any
+ license = GPL3
+ depends = libjpeg-turbo
+ depends = qt5-tools
+ depends = libpng12
+ depends = gsl
+ depends = openmpi
+ source = http://downloads.sourceforge.net/project/mandelbulber/Mandelbulber%20v2/source%20-%20multiplatform/mandelbulber2-2.04.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fmandelbulber%2Ffiles%2FMandelbulber%2520v2%2Fsource%2520-%2520multiplatform%2F&ts=1438647832&use_mirror=iweb
+ md5sums = 4f0d86a0f460ffa2f2a2a5a2072a977a
+
+pkgname = mandelbulber2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc8770d13285
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Author: Madotsuki <madotsuki@national.shitposting.agency>
+
+pkgname=mandelbulber2
+pkgver=2.04
+pkgrel=1
+pkgdesc="3D application designed to render 3D fractals such as the Mandelbulb, Mandelbox, BulbBox, JuliaBulb, Menger Sponge, and Iterated Function Systems. Rewritten from scratch with new Qt based interface."
+arch=('any')
+url="http://www.mandelbulber.com/"
+license=('GPL3')
+depends=('libjpeg-turbo' 'qt5-tools' 'libpng12' 'gsl' 'openmpi')
+source=('http://downloads.sourceforge.net/project/mandelbulber/Mandelbulber%20v2/source%20-%20multiplatform/mandelbulber2-2.04.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fmandelbulber%2Ffiles%2FMandelbulber%2520v2%2Fsource%2520-%2520multiplatform%2F&ts=1438647832&use_mirror=iweb')
+md5sums=('4f0d86a0f460ffa2f2a2a5a2072a977a')
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver/makefiles"
+ qmake mandelbulber.pro
+ make PREFIX=/usr all
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver/makefiles"
+ make PREFIX=/usr install
+}