summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadotsuki2015-08-03 21:18:57 -0500
committermadotsuki2015-08-03 21:18:57 -0500
commita634fc7c26824fde58ac9b7c94eb9bc478a76260 (patch)
tree0e1a1092bfc12e24e15d315c77d2d548c95b53f9
downloadaur-a634fc7c26824fde58ac9b7c94eb9bc478a76260.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa38fc2a006c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mandelbulber2-git
+ pkgdesc = 3D application designed to render 3D fractals such as the Mandelbulb, Mandelbox, BulbBox, JuliaBulb, Menger Sponge, and Iterated Function Systems. Git version.
+ pkgver = 20150804
+ pkgrel = 1
+ url = https://github.com/buddhi1980/mandelbulber2
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = qt5-tools
+ depends = libjpeg-turbo
+ depends = libpng12
+ depends = gsl
+ depends = openmpi
+ provides = mandelbulber2
+ conflicts = mandelbulber2
+ source = mandelbulber2::git+https://github.com/buddhi1980/mandelbulber2
+ md5sums = SKIP
+
+pkgname = mandelbulber2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..385fcf42abee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Author: Madotsuki <madotsuki@national.shitposting.agency>
+
+pkgname=mandelbulber2-git
+_pkgname=mandelbulber2
+pkgver=20150804
+pkgrel=1
+pkgdesc="3D application designed to render 3D fractals such as the Mandelbulb, Mandelbox, BulbBox, JuliaBulb, Menger Sponge, and Iterated Function Systems. Git version."
+arch=('any')
+url="https://github.com/buddhi1980/mandelbulber2"
+license=('GPL3')
+depends=('qt5-tools' 'libjpeg-turbo' 'libpng12' 'gsl' 'openmpi')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${_pkgname}::git+https://github.com/buddhi1980/mandelbulber2")
+md5sums=('SKIP')
+
+pkgver()
+{
+ cd $_pkgname
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build()
+{
+ cd $_pkgname/$_pkgname/Release
+ qmake-qt5 mandelbulber.pro
+ make PREFIX=/usr
+}
+
+package()
+{
+ cd "$srcdir/$_pkgname"
+
+ install -m755 -d "${pkgdir}/usr/bin"
+ install -D -m644 "${srcdir}/${_pkgname}/${_pkgname}/deploy/linux/mandelbulber2.desktop" "${pkgdir}/usr/share/applications/mandelbulber2.desktop"
+
+ install -m755 -d "${pkgdir}/usr/share/${_pkgname}"
+ install -m755 -d "${pkgdir}/usr/share/applications"
+ install -m755 -d "${pkgdir}/usr/share/icons"
+
+ cp -ra "${srcdir}/${_pkgname}/${_pkgname}/qt" "$pkgdir/usr/share/${_pkgname}/qt"
+ install -m755 "${srcdir}/${_pkgname}/${_pkgname}/Release/mandelbulber2" "${pkgdir}/usr/bin/"
+}
+