summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-12-09 11:15:56 +1100
committerStephen Gregoratto2019-12-09 11:20:02 +1100
commitffbfd9e087d7c5383c440248f170a9e90cd179a4 (patch)
tree89699f83ac85c825309db172034f466883166653
parent20ca34bfe1d16d34fe99acdde2764c00d116435b (diff)
downloadaur-ffbfd9e087d7c5383c440248f170a9e90cd179a4.tar.gz
pick up CPP/C/LDFLAGS from the environment
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--configure.local3
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9690f9f84f3..2e4952483704 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mandoc-cvs
pkgdesc = A suite of tools compiling mdoc from the OpenBSD project
- pkgver = 20190612
+ pkgver = 20191111
pkgrel = 1
url = https://mandoc.bsd.lv
arch = i686
@@ -16,7 +16,7 @@ pkgbase = mandoc-cvs
source = configure.local
source = mandoc.service
source = mandoc.timer
- sha256sums = f0e8ddb61d063bec02a6a1f73f5d979bb548e7aabcf0a27c0d5c29c4194bfc8e
+ sha256sums = 8d1301ac6e52653fedda5b862428f0b21976664005c7b3da24bf4e411d7bb56d
sha256sums = 2091411d5f87a3c371a5ba74b4773d1e454046446fa2cb045485979e52419bb6
sha256sums = 74d6a02b97a17fffddcc0a3dc830e811348b1f6c6b84f867882c776d50f00ea4
diff --git a/PKGBUILD b/PKGBUILD
index ec419e5dca29..de42268c3ad8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
pkgname=mandoc-cvs
-pkgver=20190612
+pkgver=20191111
pkgrel=1
pkgdesc='A suite of tools compiling mdoc from the OpenBSD project'
license=('custom: ISC')
@@ -16,7 +16,7 @@ conflicts=('man')
source=('configure.local'
'mandoc.service'
'mandoc.timer')
-sha256sums=('f0e8ddb61d063bec02a6a1f73f5d979bb548e7aabcf0a27c0d5c29c4194bfc8e'
+sha256sums=('8d1301ac6e52653fedda5b862428f0b21976664005c7b3da24bf4e411d7bb56d'
'2091411d5f87a3c371a5ba74b4773d1e454046446fa2cb045485979e52419bb6'
'74d6a02b97a17fffddcc0a3dc830e811348b1f6c6b84f867882c776d50f00ea4')
@@ -38,8 +38,12 @@ pkgver() {
}
build() {
- cp "${srcdir}/configure.local" $pkgname
cd $pkgname
+ cat "$srcdir/configure.local" - <<EOF > configure.local
+CPPFLAGS="$CPPFLAGS"
+CFLAGS="$CFLAGS"
+LDFLAGS="$LDFLAGS"
+EOF
./configure
make
}
diff --git a/configure.local b/configure.local
index 8abc16b1b840..1180aad2d880 100644
--- a/configure.local
+++ b/configure.local
@@ -17,5 +17,4 @@ MANM_ROFF=mandoc_roff
# catman(8) is disabled by default.
BUILD_CATMAN=1
-# _FORTIFY_SOURCE doesn't work unless an optimisation level is specified.
-CFLAGS="$CFLAGS -O2"
+