summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorC. Dominik Bódi2015-08-19 16:35:19 +0200
committerC. Dominik Bódi2015-08-19 16:35:19 +0200
commit1f272c602426ab0e39361e05b9b59ff0f9bc40e1 (patch)
treebdbefa747792dfd0e3e9a8730467bf47723d28c9
parent42e45e59d3a783374a8d5979acfa44d3d31e4e05 (diff)
downloadaur-1f272c602426ab0e39361e05b9b59ff0f9bc40e1.tar.gz
* updated to upstream version 1.7.0
* use quilt for patching, enables simple patch refresh
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--fix_makefile.patch12
-rw-r--r--series1
4 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 757335689d76..3e43755c7df6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mandos-server
pkgdesc = unlock LUKS encrypted drives remotely - server component
- pkgver = 1.6.9
+ pkgver = 1.7.0
pkgrel = 1
url = https://wiki.recompile.se/wiki/Mandos
install = mandos.install
@@ -23,10 +23,12 @@ pkgbase = mandos-server
backup = etc/mandos/mandos.conf
backup = etc/mandos/clients.conf
backup = etc/dbus-1/system.d/mandos.conf
- source = http://ftp.recompile.se/pub/mandos/mandos_1.6.9.orig.tar.gz
+ source = http://httpredir.debian.org/debian/pool/main/m/mandos/mandos_1.7.0.orig.tar.gz
+ source = series
source = fix_makefile.patch
- sha256sums = bf04b7786c5c29409ca48454de25aa3e70f2bbd3428a393d3424069f89e3a40e
- sha256sums = 73af9f42039d4b843f13ca3985ec5ab4809ecd092c2f229db57e36deb671b54d
+ sha256sums = 37f145c575d4b49eaa2d0b6ed8067d1e4687f7fa3927b6154f7a5d7907ba947a
+ sha256sums = d5d2d190799efdc4ecba1221a405983a3e770b085f055c1c156199436836dc47
+ sha256sums = e51e3db7faa66af3bc307c7a2503b2b23d702896a5027660a01d3cc2e4dedb1b
pkgname = mandos-server
diff --git a/PKGBUILD b/PKGBUILD
index 41182b66d587..e58ea3a97ad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: C. Dominik Bódi <dominik.bodi@dominikbodi.de>
pkgname=mandos-server
_srcname=mandos
-pkgver=1.6.9
+pkgver=1.7.0
pkgrel=1
pkgdesc="unlock LUKS encrypted drives remotely - server component"
arch=(any)
@@ -19,18 +19,26 @@ depends=(avahi
openssh)
makedepends=(docbook-xml
docbook-xsl
- pkg-config)
+ pkg-config
+ quilt)
optdepends=('fping: host uptime checking - legacy method')
backup=('etc/mandos/mandos.conf'
'etc/mandos/clients.conf'
'etc/dbus-1/system.d/mandos.conf')
install=mandos.install
-source=("http://ftp.recompile.se/pub/mandos/mandos_1.6.9.orig.tar.gz"
+source=("http://httpredir.debian.org/debian/pool/main/m/mandos/mandos_$pkgver.orig.tar.gz"
+ 'series'
'fix_makefile.patch')
-sha256sums=('bf04b7786c5c29409ca48454de25aa3e70f2bbd3428a393d3424069f89e3a40e'
- '73af9f42039d4b843f13ca3985ec5ab4809ecd092c2f229db57e36deb671b54d')
+sha256sums=('37f145c575d4b49eaa2d0b6ed8067d1e4687f7fa3927b6154f7a5d7907ba947a'
+ 'd5d2d190799efdc4ecba1221a405983a3e770b085f055c1c156199436836dc47'
+ 'e51e3db7faa66af3bc307c7a2503b2b23d702896a5027660a01d3cc2e4dedb1b')
+
prepare() {
- patch -p2 -i fix_makefile.patch
+ mkdir "$_srcname-$pkgver/patches"
+ cp series "$_srcname-$pkgver/patches/"
+ cp fix_makefile.patch "$_srcname-$pkgver/patches/"
+ cd "$_srcname-$pkgver"
+ quilt push -a
}
build() {
diff --git a/fix_makefile.patch b/fix_makefile.patch
index 85477cd8b77c..7530751ba54f 100644
--- a/fix_makefile.patch
+++ b/fix_makefile.patch
@@ -1,20 +1,20 @@
---- a/src/mandos-1.6.9/Makefile
-+++ b/src/mandos-1.6.9/Makefile
-@@ -83,7 +83,7 @@ DOCBOOKTOMAN=$(strip cd $(dir $<); xsltp
+--- a/Makefile
++++ b/Makefile
+@@ -85,7 +85,7 @@ DOCBOOKTOMAN=$(strip cd $(dir $<); xsltp
--param make.single.year.ranges 1 \
--param man.output.quietly 1 \
--param man.authors.section.enabled 0 \
- /usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl \
-+ /usr/share/xml/docbook/xsl-stylesheets-1.78.1/manpages/docbook.xsl \
++ /usr/share/xml/docbook/xsl-stylesheets-1.78.1/manpages/docbook.xsl \
$(notdir $<); \
if locale --all 2>/dev/null | grep --regexp='^en_US\.utf8$$' \
&& type man 2>/dev/null; then LANG=en_US.UTF-8 MANWIDTH=80 \
-@@ -97,7 +97,7 @@ DOCBOOKTOHTML=$(strip xsltproc --nonet -
+@@ -99,7 +99,7 @@ DOCBOOKTOHTML=$(strip xsltproc --nonet -
--param man.authors.section.enabled 0 \
--param citerefentry.link 1 \
--output $@ \
- /usr/share/xml/docbook/stylesheet/nwalsh/xhtml/docbook.xsl \
-+ /usr/share/xml/docbook/xsl-stylesheets-1.78.1/manpages/docbook.xsl \
++ /usr/share/xml/docbook/xsl-stylesheets-1.78.1/manpages/docbook.xsl \
$<; $(HTMLPOST) $@)
# Fix citerefentry links
HTMLPOST=$(SED) --in-place \
diff --git a/series b/series
new file mode 100644
index 000000000000..1d3db58a56fe
--- /dev/null
+++ b/series
@@ -0,0 +1 @@
+fix_makefile.patch