summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaro942020-07-09 20:13:56 +0200
committerTaro942020-07-09 20:13:56 +0200
commit2feb6215a2151841fd846bf6e51da8d6d3368596 (patch)
treec0558e7d234605f8fdcf3148e92517dcbc39106a
downloadaur-2feb6215a2151841fd846bf6e51da8d6d3368596.tar.gz
mango package 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb79a0ebb1a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mango
+ pkgdesc = A tool for making backups of Arch packages and its dependencies
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/Taro94/mango
+ arch = any
+ license = GPL
+ makedepends = dotnet-sdk>=3.1.0
+ depends = fakepkg
+ source = https://gitlab.com/Taro94/mango/-/archive/1.0.0/mango-1.0.0.tar.gz
+ md5sums = 6abbeb989febf657b363a95c5d328421
+
+pkgname = mango
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..122a1b0eded2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Stanisław Jasiewicz <stjasiewicz@gmail.com>
+pkgname=mango
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A tool for making backups of Arch packages and its dependencies"
+arch=('any')
+url="https://gitlab.com/Taro94/mango"
+license=('GPL')
+depends=('fakepkg')
+makedepends=('dotnet-sdk>=3.1.0')
+source=("https://gitlab.com/Taro94/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('6abbeb989febf657b363a95c5d328421')
+
+build() {
+ cd "$pkgname-$pkgver"
+ dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -o published
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "published/${pkgname}" -t "$pkgdir/usr/bin"
+}