summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaro942020-07-09 21:43:08 +0200
committerTaro942020-07-09 21:43:08 +0200
commite56ccffa19f3c77ff7cbd885852461300083869c (patch)
tree0fcbb97fd88d720c77347583b1ac1a0d8b6d46ed
parent2feb6215a2151841fd846bf6e51da8d6d3368596 (diff)
downloadaur-e56ccffa19f3c77ff7cbd885852461300083869c.tar.gz
Added strip option to fix binaries
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 122a1b0eded2..f99fb7a29f6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,10 @@ depends=('fakepkg')
makedepends=('dotnet-sdk>=3.1.0')
source=("https://gitlab.com/Taro94/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
md5sums=('6abbeb989febf657b363a95c5d328421')
-
-build() {
- cd "$pkgname-$pkgver"
- dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -o published
-}
+options=(!strip)
package() {
cd "$pkgname-$pkgver"
- install -Dm 755 "published/${pkgname}" -t "$pkgdir/usr/bin"
+ dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishTrimmed=true -o published
+ install -Dm 755 "published/${pkgname}" -t "$pkgdir/bin"
}