summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-04-18 08:46:26 -0600
committerMark Wagie2023-04-18 08:46:26 -0600
commite747ef03bc661f0f32fbb7fccf363173f5bb8ed8 (patch)
tree51d1ac292ae6744b8671afb40056441d95582cca
parent231d97c1fa40fd02b3d680919e34b31121b1d10b (diff)
downloadaur-e747ef03bc661f0f32fbb7fccf363173f5bb8ed8.tar.gz
0.6.9-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d56d7ac464fc..db0981bfab2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mangohud
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more.
- pkgver = 0.6.9
+ pkgver = 0.6.9.1
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = mangohud
makedepends = nlohmann-json
makedepends = python-mako
makedepends = spdlog
- source = git+https://github.com/flightlessmango/MangoHud.git#commit=5fa7087f78e39e92ee4306fdf48fd710960c53dc
+ source = git+https://github.com/flightlessmango/MangoHud.git#commit=7f945627f57ecc56afea342c2dc0544d0d43728e
source = git+https://github.com/flightlessmango/minhook.git
source = https://github.com/ocornut/imgui/archive/refs/tags/v1.81/imgui-1.81.tar.gz
source = https://wrapdb.mesonbuild.com/v2/imgui_1.81-1/get_patch#/imgui-1.81-1-wrap.zip
diff --git a/PKGBUILD b/PKGBUILD
index ba1a5235409d..e02a6f4897a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=('mangohud' 'mangoapp' 'mangohud-common')
pkgbase=mangohud
-pkgver=0.6.9
+pkgver=0.6.9.1
pkgrel=1
_imgui_ver=1.81
_vulkan_ver=1.2.158
@@ -12,7 +12,7 @@ url="https://github.com/flightlessmango/MangoHud"
license=('MIT')
makedepends=('appstream' 'cmocka' 'dbus' 'git' 'glew' 'glfw-x11' 'glslang' 'libglvnd'
'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'spdlog')
-_commit=5fa7087f78e39e92ee4306fdf48fd710960c53dc # tags/v0.6.9^0
+_commit=7f945627f57ecc56afea342c2dc0544d0d43728e # tags/v0.6.9-1^0
source=("git+https://github.com/flightlessmango/MangoHud.git#commit=${_commit}"
'git+https://github.com/flightlessmango/minhook.git'
"https://github.com/ocornut/imgui/archive/refs/tags/v${_imgui_ver}/imgui-${_imgui_ver}.tar.gz"
@@ -28,7 +28,8 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/MangoHud"
- git describe --tags | sed 's/^v//;s/-/+/g'
+# git describe --tags | sed 's/^v//;s/-/+/g'
+ git describe --tags | sed 's/^v//;s/-/./g'
}
prepare() {
@@ -60,8 +61,7 @@ local meson_options=(
}
check() {
- cd "$srcdir/MangoHud"
- appstreamcli validate --no-net --pedantic "data/io.github.flightlessmango.$pkgbase.metainfo.xml"
+ meson test -C build --print-errorlogs || :
}
package_mangohud() {