summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanieri Althoff2020-02-19 19:20:40 -0300
committerRanieri Althoff2020-02-19 19:20:40 -0300
commited9b1b0ef1999b544f12d3bbdbcce4377de39172 (patch)
tree159302b54db4f271ff631292e2e13432ff2233d4
parenteca0b1ed7484547b251749f39544c8eb1369b06b (diff)
downloadaur-ed9b1b0ef1999b544f12d3bbdbcce4377de39172.tar.gz
v0.2.0-3
- Add missing dependencies - Replace git clone with archive download
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8c68145bde6..742d80a2a037 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mangohud
pkgver = 0.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
@@ -10,12 +10,14 @@ pkgbase = mangohud
makedepends = libglvnd
makedepends = lib32-libglvnd
makedepends = vulkan-headers
+ makedepends = vulkan-icd-loader
+ makedepends = lib32-vulkan-icd-loader
depends = gcc-libs
depends = libx11
- source = mangohud::git+https://github.com/flightlessmango/MangoHud.git#tag=v0.2.0
- source = ImGui::git+https://github.com/flightlessmango/ImGui.git
- sha512sums = SKIP
- sha512sums = SKIP
+ source = https://github.com/flightlessmango/MangoHud/archive/v0.2.0.tar.gz
+ source = https://github.com/flightlessmango/imgui/archive/6c1a73774dabd2be64f85543b1286e44632d1905.tar.gz
+ sha256sums = 61ec5cb9c9e61eec89a68af305ceb99f16487f85e25127f21b8ecd66a67d12c0
+ sha256sums = 22ed2689e14f6e5cbd602edcd368562ba118abaf5d7ab42d33a5eb10a77cb687
pkgname = mangohud
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more
diff --git a/PKGBUILD b/PKGBUILD
index 3bf85a4a7eb5..4cfd7c2fa232 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+_imgui_commit='6c1a73774dabd2be64f85543b1286e44632d1905'
+
pkgbase=mangohud
pkgname=('mangohud' 'lib32-mangohud')
pkgver=0.2.0
-pkgrel=2
+pkgrel=3
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
depends=('gcc-libs' 'libx11')
makedepends=('meson' 'python-mako' 'glslang' 'libglvnd' 'lib32-libglvnd'
- 'vulkan-headers')
-source=("$pkgbase::git+$url.git#tag=v$pkgver"
- 'ImGui::git+https://github.com/flightlessmango/ImGui.git')
-sha512sums=('SKIP'
- 'SKIP')
+ 'vulkan-headers' 'vulkan-icd-loader' 'lib32-vulkan-icd-loader')
+source=("https://github.com/flightlessmango/MangoHud/archive/v$pkgver.tar.gz"
+ "https://github.com/flightlessmango/imgui/archive/$_imgui_commit.tar.gz")
+sha256sums=('61ec5cb9c9e61eec89a68af305ceb99f16487f85e25127f21b8ecd66a67d12c0'
+ '22ed2689e14f6e5cbd602edcd368562ba118abaf5d7ab42d33a5eb10a77cb687')
+
+_srcdir="MangoHud-$pkgver"
prepare() {
- cd "$pkgbase"
- git submodule init
- git config submodule.'modules/ImGui/src'.url "$srcdir/ImGui"
- git submodule update
+ rmdir "$_srcdir/modules/ImGui/src"
+ ln -sr "imgui-$_imgui_commit" "$_srcdir/modules/ImGui/src"
}
build() {
- arch-meson -Duse_system_vulkan=enabled "$pkgbase" build64
+ arch-meson -Duse_system_vulkan=enabled "$_srcdir" build64
ninja -C build64
export CC="gcc -m32"
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
export LLVM_CONFIG="/usr/bin/llvm-config32"
- arch-meson -Duse_system_vulkan=enabled "$pkgbase" build32 --libdir lib32
+ arch-meson -Duse_system_vulkan=enabled "$_srcdir" build32 --libdir lib32
ninja -C build32
}
@@ -42,7 +44,7 @@ package_mangohud() {
mv "$pkgdir/usr/share/vulkan/implicit_layer.d/"mangohud{,64}.json
sed -i -e 's|libMangoHud.so|/usr/lib/&|g' "$pkgdir/usr/share/vulkan/implicit_layer.d/mangohud64.json"
- install -Dm644 "$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$_srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_lib32-mangohud() {
@@ -53,5 +55,5 @@ package_lib32-mangohud() {
mv "$pkgdir/usr/share/vulkan/implicit_layer.d/"mangohud{,32}.json
sed -i -e 's|libMangoHud.so|/usr/lib32/&|g' -e 's|64bit|32bit|g' "$pkgdir/usr/share/vulkan/implicit_layer.d/mangohud32.json"
- install -Dm644 "$pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$_srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}