summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2024-03-03 12:06:27 -0400
committerDarvin Delgado2024-03-03 12:06:27 -0400
commit4f0af36a12f2f2dd53f215f46b7b868aa8f7fd0a (patch)
tree2f26421be2cb765d1ade15000d8242a031365a50
parent62406ccc52bcbe69aefe276cf0ded38383bbf887 (diff)
downloadaur-mangohud-git.tar.gz
enable mangoapp and add libxkbcommon as a makedep
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 29 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3af6a23c0b88..290afb4402ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = mangohud-git
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more.
- pkgver = 0.7.1.r0.g48d8426
+ pkgver = 0.7.1.r20.g5598fda
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
- makedepends = git
makedepends = appstream
makedepends = cmocka
+ makedepends = git
+ makedepends = glfw
makedepends = glslang
makedepends = libxnvctrl
+ makedepends = libxrandr
makedepends = meson
makedepends = nlohmann-json
makedepends = python-mako
@@ -23,14 +25,17 @@ pkgbase = mangohud-git
depends = libx11
depends = python-matplotlib
depends = python-numpy
- depends = sdl2
- depends = spdlog
depends = vulkan-icd-loader
optdepends = libxnvctrl: NVIDIA GPU stats by XNVCtrl
+ optdepends = glfw: Required for MangoApp
+ optdepends = gamescope: Use MangoApp as an overlay within gamescope
provides = mangohud
+ provides = mangoapp
conflicts = mangohud
conflicts = mangohud-common-git
- source = mangohud-git::git+https://github.com/flightlessmango/MangoHud
+ conflicts = mangoapp
+ replaces = mangoapp
+ source = git+https://github.com/flightlessmango/MangoHud
sha512sums = SKIP
pkgname = mangohud-git
diff --git a/.gitignore b/.gitignore
index 1048b52b32c4..7bc3dc013f6d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+MangoHud
mangohud
mangohud-git
src
diff --git a/PKGBUILD b/PKGBUILD
index f18f9e0d3c1e..17bf83f8dee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
+_pkgname=MangoHud
pkgname=mangohud-git
-pkgver=0.7.1.r0.g48d8426
+pkgver=0.7.1.r20.g5598fda
pkgrel=1
pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more."
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'appstream' 'cmocka' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
-depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python-matplotlib' 'python-numpy' 'sdl2' 'spdlog' 'vulkan-icd-loader')
-optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl')
-provides=('mangohud')
-conflicts=('mangohud' 'mangohud-common-git')
-source=("$pkgname::git+$url")
+makedepends=('appstream' 'cmocka' 'git' 'glfw' 'glslang' 'libxnvctrl' 'libxrandr' 'meson' 'nlohmann-json' 'python-mako' 'vulkan-headers')
+depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python-matplotlib' 'python-numpy' 'vulkan-icd-loader')
+optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl'
+ 'glfw: Required for MangoApp'
+ 'gamescope: Use MangoApp as an overlay within gamescope')
+provides=('mangohud' 'mangoapp')
+replaces=('mangoapp')
+conflicts=('mangohud' 'mangohud-common-git' 'mangoapp')
+source=("git+$url")
sha512sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd $_pkgname
git describe --tags --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- local meson_options=(
+ arch-meson "$_pkgname" build \
+ -Dmangoapp=true \
+ -Dmangohudctl=true \
+ -Dmangoapp_layer=true \
--wrap-mode=nofallback
- -Dwith_wayland=enabled
- $pkgname
- )
- arch-meson "${meson_options[@]}" build
meson compile -C build
+
}
package() {
meson install -C build --destdir "$pkgdir"
- install -Dm 0664 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 0644 "$_pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}