summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2020-09-05 21:27:19 -0400
committerDarvin Delgado2020-09-05 21:27:19 -0400
commit79b383ff407f8a8044b894ad5c5359121a1d91fc (patch)
tree1a06756811e805e9ae83e8b208599f0f14dda9e9
parent8e43dc55c672cde8dcacede4317aef687b2649c8 (diff)
downloadaur-79b383ff407f8a8044b894ad5c5359121a1d91fc.tar.gz
file conflicts fixed
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD52
2 files changed, 36 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1bfd0b68cd6..a6d373b7992c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,37 @@
pkgbase = mangohud-git
- pkgver = 0.4.1.r92.gb07db5d
+ pkgver = 0.5.1.r18.g9391822
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
- makedepends = gcc
makedepends = meson
makedepends = python-mako
- makedepends = libx11
- makedepends = lib32-libx11
- makedepends = libxnvctrl
- makedepends = git
+ makedepends = glslang
+ makedepends = libglvnd
+ makedepends = lib32-libglvnd
makedepends = vulkan-headers
- depends = glslang
- depends = libglvnd
- depends = lib32-libglvnd
- depends = libxnvctrl
- depends = lib32-vulkan-icd-loader
- depends = vulkan-icd-loader
+ makedepends = vulkan-icd-loader
+ makedepends = lib32-vulkan-icd-loader
+ makedepends = libxnvctrl
replaces = vulkan-mesa-layer-mango
replaces = lib32-vulkan-mesa-layer-mango
source = mangohud::git+https://github.com/flightlessmango/MangoHud#branch=develop
- source = ImGui::git+https://github.com/flightlessmango/ImGui.git
- sha512sums = SKIP
sha512sums = SKIP
pkgname = mangohud-git
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more
+ depends = gcc-libs
+ depends = mangohud-common-git
+ optdepends = bash: mangohud helper script
+ optdepends = libxnvctrl: support for older NVIDIA GPUs
conflicts = mangohud
pkgname = lib32-mangohud-git
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32-bit)
+ depends = lib32-gcc-libs
+ depends = mangohud-git
+ depends = mangohud-common-git
+ optdepends = lib32-libxnvctrl: support for older NVIDIA GPUs
conflicts = lib32-mangohud
pkgname = mangohud-common-git
diff --git a/PKGBUILD b/PKGBUILD
index ef6819733906..a07496150c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,75 +3,65 @@
_pkgbase=mangohud
pkgbase=$_pkgbase-git
pkgname=('mangohud-git' 'lib32-mangohud-git' 'mangohud-common-git')
-pkgver=0.4.1.r92.gb07db5d
+pkgver=0.5.1.r18.g9391822
pkgrel=1
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-depends=('glslang' 'libglvnd' 'lib32-libglvnd' 'libxnvctrl' 'lib32-vulkan-icd-loader' 'vulkan-icd-loader')
-makedepends=('gcc' 'meson' 'python-mako' 'libx11' 'lib32-libx11' 'libxnvctrl' 'git' 'vulkan-headers')
+makedepends=('meson' 'python-mako' 'glslang' 'libglvnd' 'lib32-libglvnd'
+ 'vulkan-headers' 'vulkan-icd-loader' 'lib32-vulkan-icd-loader'
+ 'libxnvctrl')
replaces=('vulkan-mesa-layer-mango' 'lib32-vulkan-mesa-layer-mango')
-source=("$_pkgbase::git+$url#branch=develop"
- 'ImGui::git+https://github.com/flightlessmango/ImGui.git')
-sha512sums=('SKIP'
- 'SKIP')
+source=("$_pkgbase::git+$url#branch=develop")
+sha512sums=('SKIP')
pkgver() {
cd "$_pkgbase"
git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
-prepare() {
- cd "$_pkgbase"
- git submodule init
- git config submodule.'modules/ImGui/src'.url "$srcdir/ImGui"
- git submodule update
-}
build() {
- arch-meson "$_pkgbase" build64 \
- --libdir lib/mangohud/lib64 \
- --prefix /usr \
- -Dappend_libdir_mangohud=false \
- -Dinclude_doc=false \
- -Duse_system_vulkan=enabled
-
+ arch-meson -Dappend_libdir_mangohud=false -Duse_system_vulkan=enabled "$_pkgbase" build64
ninja -C build64
export CC="gcc -m32"
export CXX="g++ -m32"
- export PKG_CONFIG_PATH="/usr/lib32/pkgconfig:/usr/lib/i386-linux-gnu/pkgconfig:/usr/lib/pkgconfig:${PKG_CONFIG_PATH_32}"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
export LLVM_CONFIG="/usr/bin/llvm-config32"
-
- arch-meson "$_pkgbase" build32 \
- --libdir lib/mangohud/lib32 \
- --prefix /usr \
- -Dappend_libdir_mangohud=false \
- -Dinclude_doc=false \
- -Duse_system_vulkan=enabled
-
+ arch-meson -Dappend_libdir_mangohud=false -Duse_system_vulkan=enabled "$_pkgbase" build32 --libdir lib32
ninja -C build32
}
package_mangohud-git() {
pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more'
+ depends=('gcc-libs' 'mangohud-common-git')
conflicts=('mangohud')
+ optdepends=('bash: mangohud helper script'
+ 'libxnvctrl: support for older NVIDIA GPUs')
DESTDIR="$pkgdir" ninja -C build64 install
+ rm -r "$pkgdir/usr/bin" "$pkgdir/usr/share/doc" "$pkgdir/usr/share/man"
}
package_lib32-mangohud-git() {
pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more (32-bit)'
+ depends=('lib32-gcc-libs' 'mangohud-git' 'mangohud-common-git')
conflicts=('lib32-mangohud')
+ optdepends=('lib32-libxnvctrl: support for older NVIDIA GPUs')
DESTDIR="$pkgdir" ninja -C build32 install
- rm -r "$pkgdir/usr/share/man"
+ rm -r "$pkgdir/usr/bin" "$pkgdir/usr/share/doc" "$pkgdir/usr/share/man"
+ mv "$pkgdir/usr/share/vulkan/implicit_layer.d/MangoHud.json" "$pkgdir/usr/share/vulkan/implicit_layer.d/MangoHud.x86.json"
}
package_mangohud-common-git() {
pkgdesc='A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more'
conflicts=('mangohud-common')
- install -Dm664 "$_pkgbase/bin/MangoHud.conf" "$pkgdir/usr/share/doc/mangohud/MangoHud.conf.example"
+ DESTDIR="$pkgdir" ninja -C build64 install
+ rm -r "$pkgdir/usr/lib" "$pkgdir/usr/share/vulkan"
+
+ install -Dm664 "$_pkgbase/bin/MangoHud.conf" "$pkgdir/usr/share/doc/mangohud/MangoHud.conf"
install -Dm664 "$_pkgbase/LICENSE" "$pkgdir/usr/share/licenses/$_pkgbase/LICENSE"
}