summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2021-01-09 13:39:43 -0400
committerDarvin Delgado2021-01-09 13:39:43 -0400
commitc784ea14ce067cd5320bb7c4fad5a8fafe3e765f (patch)
treebe7bc91df8b8e0150d8a3c2c87ada642398698f7
parent79b383ff407f8a8044b894ad5c5359121a1d91fc (diff)
downloadaur-c784ea14ce067cd5320bb7c4fad5a8fafe3e765f.tar.gz
compile error fixed
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD7
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6d373b7992c..b25456f4547a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = mangohud-git
- pkgver = 0.5.1.r18.g9391822
+ pkgver = 0.6.1.r46.gc92f805
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 78d15517d0af..481375e4a41f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,8 @@
+mangohud
src
pkg
*.tar.xz
*.tar.gz
+*.pkg.tar.zst
*.log
-ImGui
-mangohud
+.directory
diff --git a/PKGBUILD b/PKGBUILD
index a07496150c78..3e410c8e544a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=mangohud
pkgbase=$_pkgbase-git
pkgname=('mangohud-git' 'lib32-mangohud-git' 'mangohud-common-git')
-pkgver=0.5.1.r18.g9391822
+pkgver=0.6.1.r46.gc92f805
pkgrel=1
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
@@ -22,7 +22,10 @@ pkgver() {
build() {
- arch-meson -Dappend_libdir_mangohud=false -Duse_system_vulkan=enabled "$_pkgbase" build64
+ arch-meson --wrap-mode=forcefallback \
+ -Dappend_libdir_mangohud=false \
+ -Duse_system_vulkan=enabled "$_pkgbase" build64
+
ninja -C build64
export CC="gcc -m32"