summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2020-04-05 13:20:47 -0400
committerDarvin Delgado2020-04-05 13:20:47 -0400
commitfe4f9a889253a53d947eb09c6df6afa9aa78b94b (patch)
tree5e1443f476f90d5427343c209f20214ad4ac7be9
parenta180f1e7cf87e184414c697aaf45c283e732fadf (diff)
downloadaur-fe4f9a889253a53d947eb09c6df6afa9aa78b94b.tar.gz
added -Duse_system_vulkan=enabled to every arch-meson command
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD14
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdb6d697a446..b817ff767ac2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mangohud-git
- pkgver = 0.3.0.r28.g32c4515
- pkgrel = 2
+ pkgver = 0.3.1.r80.ga6bfa71
+ pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
@@ -11,11 +11,13 @@ pkgbase = mangohud-git
makedepends = lib32-libx11
makedepends = libxnvctrl
makedepends = git
+ makedepends = vulkan-headers
depends = glslang
depends = libglvnd
depends = lib32-libglvnd
depends = libxnvctrl
- depends = vulkan-headers
+ depends = lib32-vulkan-icd-loader
+ depends = vulkan-icd-loader
replaces = vulkan-mesa-layer-mango
replaces = lib32-vulkan-mesa-layer-mango
source = mangohud::git+https://github.com/flightlessmango/MangoHud#branch=develop
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78d15517d0af
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.log
+ImGui
+mangohud
diff --git a/PKGBUILD b/PKGBUILD
index 553697a3d3e2..dc84ecc566c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgbase=mangohud
pkgbase=$_pkgbase-git
pkgname=('mangohud-git' 'lib32-mangohud-git' 'mangohud-common-git')
-pkgver=0.3.0.r28.g32c4515
-pkgrel=2
+pkgver=0.3.1.r80.ga6bfa71
+pkgrel=1
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-depends=('glslang' 'libglvnd' 'lib32-libglvnd' 'libxnvctrl' 'vulkan-headers')
-makedepends=('gcc' 'meson' 'python-mako' 'libx11' 'lib32-libx11' 'libxnvctrl' 'git')
+depends=('glslang' 'libglvnd' 'lib32-libglvnd' 'libxnvctrl' 'lib32-vulkan-icd-loader' 'vulkan-icd-loader')
+makedepends=('gcc' 'meson' 'python-mako' 'libx11' 'lib32-libx11' 'libxnvctrl' 'git' 'vulkan-headers')
replaces=('vulkan-mesa-layer-mango' 'lib32-vulkan-mesa-layer-mango')
source=("$_pkgbase::git+$url#branch=develop"
'ImGui::git+https://github.com/flightlessmango/ImGui.git')
@@ -33,7 +33,8 @@ build() {
--libdir lib/mangohud/lib64 \
--prefix /usr \
-Dappend_libdir_mangohud=false \
- -Dinclude_doc=false
+ -Dinclude_doc=false \
+ -Duse_system_vulkan=enabled
ninja -C build64
@@ -46,7 +47,8 @@ build() {
--libdir lib/mangohud/lib32 \
--prefix /usr \
-Dappend_libdir_mangohud=false \
- -Dinclude_doc=false
+ -Dinclude_doc=false \
+ -Duse_system_vulkan=enabled
ninja -C build32
}