summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2021-02-02 10:07:48 +0100
committerGroctel2021-02-02 10:07:48 +0100
commit1263925dff3900270b82d13b774300ea51b5e945 (patch)
treec858c71dd1dab9297a4e2724e70fc342a6e3a6fb
parentbf31939167a530866128c0efddcaf0c6f631553d (diff)
downloadaur-1263925dff3900270b82d13b774300ea51b5e945.tar.gz
Updated to 0.3.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 8 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 884d53e98d51..14bd28d7d59a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,29 @@
pkgbase = manimce
pkgdesc = Animation engine for explanatory math videos (community edition).
- pkgver = 0.2.0
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/ManimCommunity/manim/
arch = any
license = MIT
license = custom
- makedepends = sed
+ makedepends = python-setuptools
depends = python
- depends = cairo
depends = ffmpeg
- depends = python
- depends = python-black
depends = python-cairo
depends = python-colour
- depends = python-grpcio
- depends = python-guzzle-sphinx-theme
- depends = python-matplotlib
depends = python-networkx
depends = python-numpy
depends = python-pillow
depends = python-pygments
- depends = python-pylint
- depends = python-pytest
- depends = python-recommonmark
depends = python-rich
depends = python-scipy
depends = python-tqdm
- depends = python-watchdog
- depends = python-grpcio-tools
depends = python-manimpango
depends = python-pydub
optdepends = texlive-most: latex support
conflicts = python-manimlib
- source = https://github.com/ManimCommunity/manim/releases/download/v0.2.0/manim-0.2.0.tar.gz
- sha256sums = 01925f8550b5dd96275259e1943a12216d18f851202aa88abde16d660148638f
+ source = https://github.com/ManimCommunity/manim/releases/download/v0.3.0/manim-0.3.0.tar.gz
+ sha256sums = 87166696E0D1D841C5721C545C55209FA4B6DCE95F0327B79EB8EF3DEBC8C11B
pkgname = manim-community
diff --git a/PKGBUILD b/PKGBUILD
index e76685257110..d30aacd2d606 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=manimce
pkgname=manim-community
_name=manim
-pkgver=0.2.0
+pkgver=0.3.0
pkgrel=1
pkgdesc="Animation engine for explanatory math videos (community edition)."
arch=('any')
@@ -10,34 +10,22 @@ url="https://github.com/ManimCommunity/manim/"
license=('MIT' 'custom')
depends=(
'python'
- 'cairo'
'ffmpeg'
- 'python'
- 'python-black'
'python-cairo'
'python-colour'
- 'python-grpcio'
- 'python-guzzle-sphinx-theme'
- 'python-matplotlib'
'python-networkx'
'python-numpy'
'python-pillow'
'python-pygments'
- 'python-pylint'
- 'python-pytest'
- 'python-recommonmark'
'python-rich'
'python-scipy'
'python-tqdm'
- 'python-watchdog'
-
# Aur dependencies
- 'python-grpcio-tools'
'python-manimpango'
'python-pydub'
)
makedepends=(
- 'sed'
+ 'python-setuptools'
)
optdepends=(
'texlive-most: latex support'
@@ -45,11 +33,10 @@ optdepends=(
conflicts=('python-manimlib')
provides=()
source=("https://github.com/ManimCommunity/$_name/releases/download/v$pkgver/$_name-$pkgver.tar.gz")
-sha256sums=('01925f8550b5dd96275259e1943a12216d18f851202aa88abde16d660148638f')
+sha256sums=('87166696E0D1D841C5721C545C55209FA4B6DCE95F0327B79EB8EF3DEBC8C11B')
prepare() {
cd "$srcdir/$_name-$pkgver"
- sed -i "/'progressbar',/d" setup.py
sed -i 's/rich>=6.0,<7.0/rich/' setup.py
}
@@ -64,3 +51,4 @@ package() {
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
install -D -m644 LICENSE.community "$pkgdir/usr/share/licenses/$_name/LICENSE.community"
}
+