summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2020-10-24 16:29:11 +0200
committerGroctel2020-10-24 16:29:11 +0200
commit1a5877e9b44cc330898968634c338757c654af6a (patch)
tree628650ebee6b2cffe7b164e3372bf46ac3348770
downloadaur-1a5877e9b44cc330898968634c338757c654af6a.tar.gz
First commit: The package can be installed
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD48
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bf3f95e26f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = manimce
+ pkgdesc = Animation engine for explanatory math videos (community edition).
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/ManimCommunity/manim/
+ arch = any
+ license = MIT
+ makedepends = python-poetry
+ depends = cairo
+ depends = ffmpeg
+ depends = python
+ depends = python-cairocffi
+ depends = python-colour
+ depends = python-numpy
+ depends = python-pillow
+ depends = python-progressbar
+ depends = python-pygments
+ depends = python-rich
+ depends = python-scipy
+ depends = python-tqdm
+ depends = python-watchdog
+ depends = python-pydub
+ optdepends = texlive-most: latex support
+ source = https://files.pythonhosted.org/packages/f9/17/5b538d8350983c9a3baaaaa0345a0def774be463c909f61d56798a275089/manimce-0.1.0.tar.gz
+ sha256sums = 402c0c91efe29375ba2a6306d48147b827922f34a3f5e3bef792829751dce550
+
+pkgname = manimce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8001495b7e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Groctel <aur@taxorubio.com>
+pkgname=manimce
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Animation engine for explanatory math videos (community edition)."
+arch=('any')
+url="https://github.com/ManimCommunity/manim/"
+license=('MIT')
+depends=(
+ 'cairo'
+ 'ffmpeg'
+ 'python'
+ 'python-cairocffi'
+ 'python-colour'
+ 'python-numpy'
+ 'python-pillow'
+ 'python-progressbar'
+ 'python-pygments'
+ 'python-rich'
+ 'python-scipy'
+ 'python-tqdm'
+ 'python-watchdog'
+
+ # AUR package
+ 'python-pydub'
+)
+makedepends=(
+ 'python-poetry'
+)
+checkdepends=()
+optdepends=(
+ 'texlive-most: latex support'
+)
+provides=()
+conflicts=()
+source=("https://files.pythonhosted.org/packages/f9/17/5b538d8350983c9a3baaaaa0345a0def774be463c909f61d56798a275089/manimce-0.1.0.tar.gz")
+sha256sums=('402c0c91efe29375ba2a6306d48147b827922f34a3f5e3bef792829751dce550')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}