summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2020-10-25 11:35:05 +0100
committerGroctel2020-10-25 11:35:05 +0100
commitdcf4ff707dbc1cf0dd7af402221c194eda99d8e2 (patch)
tree73e13cc5f1c0b0a9d4209a987ddf3a631e44a712
parentcf53c12781d2b0b702c0ef420ca680045b15f835 (diff)
downloadaur-dcf4ff707dbc1cf0dd7af402221c194eda99d8e2.tar.gz
Fixed pip only dependencies
-rw-r--r--PKGBUILD21
1 files changed, 20 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53f467f10c4f..69da8775c443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ depends=(
'python-colour'
'python-numpy'
'python-pillow'
- 'python-progressbar'
+ # 'python-progressbar' Doesn't work, must be installed with pip
'python-pygments'
'python-rich'
'python-scipy'
@@ -24,6 +24,10 @@ depends=(
# AUR package
'python-pydub'
)
+makedepends=(
+ 'python-pip'
+ 'python-wheel'
+)
optdepends=(
'texlive-most: latex support'
)
@@ -32,6 +36,21 @@ conflicts=('python-manimlib')
source=("https://files.pythonhosted.org/packages/f9/17/5b538d8350983c9a3baaaaa0345a0def774be463c909f61d56798a275089/manimce-0.1.0.tar.gz")
sha256sums=('402c0c91efe29375ba2a6306d48147b827922f34a3f5e3bef792829751dce550')
+prepare() {
+ pip install pip --upgrade
+ # This line may seem redundant but pangocairocffi refuses to install if
+ # pangocffi isn't already installed (and then must be installed again because
+ # the upgrading strategies always upgrade pangocffi). I'm keeping and eye on
+ # this step to make it more polite or replace it with actual arch packages
+ pip install --no-cache --force --use-feature=2020-resolver pangocffi==0.6.0
+ pip install --no-cache --force --use-feature=2020-resolver \
+ grpcio \
+ grpcio-tools \
+ pangocffi==0.6.0 \
+ pangocairocffi \
+ progressbar
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build