summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstar20002021-09-11 19:46:52 +0800
committerstar20002021-09-11 19:46:52 +0800
commite175612aa06ad5bec46cb3fd85c800d7a162c477 (patch)
tree6e0798bbf806bf7530ac497cf952b5f094eb18f5
parent8cef4f03c1483579a24b696b541ac990d7be9003 (diff)
downloadaur-manjaro-asian-input-support.tar.gz
Follow archwiki to update environment variables
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--enable-fcitx.sh11
-rw-r--r--enable-fcitx5.sh5
-rw-r--r--enable-ibus.sh10
5 files changed, 28 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc77c5a0ad67..6faa68387e17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = manjaro-asian-input-support
pkgdesc = Asian input support from Manjaro
- pkgver = 2020.12
- pkgrel = 2
+ pkgver = 2021.09
+ pkgrel = 1
url = https://gitlab.manjaro.org/packages/community/manjaro-asian-input-support
install = input-support.install
arch = any
@@ -11,12 +11,10 @@ pkgbase = manjaro-asian-input-support
conflicts = manjaro-asian-input-support-fcitx5
source = enable-fcitx.sh
source = enable-ibus.sh
- source = enable-fcitx5.sh
source = fcitx5.profile
source = ibus.desktop
- md5sums = 42db8df96db00e8fcc023b7bc9135b21
- md5sums = 1a68e770b9f426301b6a08fe8edb47f1
- md5sums = e493893ea6af38dd10d0a36e54e33a82
+ md5sums = a5bcd9553acf94b9543b41d7d260793a
+ md5sums = 7928e2fb103bafb07e32d1d36a8ab8ab
md5sums = 3578677a7102c9f8be3b9f7ea7d3d06f
md5sums = f1a9f3406f8268383149889f4816cd52
@@ -54,5 +52,5 @@ pkgname = fcitx5-input-support
optdepends = fcitx5-anthy: 日本語 | Japanese
optdepends = fcitx5-hangul: 한국어 | Korean
optdepends = fcitx5-unikey: Tiếng Việt | Vietnamese
+ optdepends = fcitx5-m17n: other languages provided by M17n(http://www.nongnu.org/m17n/)
provides = manjaro-asian-input-support-fcitx5
-
diff --git a/PKGBUILD b/PKGBUILD
index 9878816c2ae1..baa26a17de3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
-# Maintainer: Sam L. Yes <samlukeyes123@gmail.com>
# Maintainer: star2000 <i@star2000.work>
+# Contributor: Sam L. Yes <manjaroyes123@outlook.com>
# Contributor: Stefano Capitani <stefanoatmanjarodororg>
pkgbase=manjaro-asian-input-support
-pkgname=('ibus-input-support' 'fcitx-input-support' 'fcitx5-input-support')
-pkgver=2020.12
-pkgrel=2
+pkgname=(
+ 'ibus-input-support' 'fcitx-input-support' 'fcitx5-input-support'
+)
+pkgver=2021.09
+pkgrel=1
arch=('any')
url="https://gitlab.manjaro.org/packages/community/manjaro-asian-input-support"
license=('GPL')
@@ -13,13 +15,11 @@ pkgdesc='Asian input support from Manjaro'
source=(
'enable-fcitx.sh'
'enable-ibus.sh'
- 'enable-fcitx5.sh'
'fcitx5.profile'
'ibus.desktop'
)
-md5sums=('42db8df96db00e8fcc023b7bc9135b21'
- '1a68e770b9f426301b6a08fe8edb47f1'
- '3c80edd921bc4c1fc87d33ab6ada72f7'
+md5sums=('a5bcd9553acf94b9543b41d7d260793a'
+ '7928e2fb103bafb07e32d1d36a8ab8ab'
'3578677a7102c9f8be3b9f7ea7d3d06f'
'f1a9f3406f8268383149889f4816cd52')
install=input-support.install
@@ -78,8 +78,9 @@ package_fcitx5-input-support() {
'fcitx5-anthy: 日本語 | Japanese'
'fcitx5-hangul: 한국어 | Korean'
'fcitx5-unikey: Tiếng Việt | Vietnamese'
+ 'fcitx5-m17n: other languages provided by M17n(http://www.nongnu.org/m17n/)'
)
provides=("${pkgbase}-fcitx5")
- install -Dm644 "$srcdir/enable-fcitx5.sh" "$pkgdir/etc/profile.d/input-support.sh"
+ install -Dm644 "$srcdir/enable-fcitx.sh" "$pkgdir/etc/profile.d/input-support.sh"
install -Dm644 "$srcdir/fcitx5.profile" "$pkgdir/etc/xdg/fcitx5/profile"
}
diff --git a/enable-fcitx.sh b/enable-fcitx.sh
index c4a077f0470e..bb4f2e1725c7 100644
--- a/enable-fcitx.sh
+++ b/enable-fcitx.sh
@@ -1,5 +1,8 @@
# https://wiki.archlinux.org/index.php/Fcitx
-#im=fcitx
-export GTK_IM_MODULE=fcitx
-export QT_IM_MODULE=fcitx
-export XMODIFIERS=@im=fcitx
+# https://wiki.archlinux.org/index.php/Fcitx5
+im=fcitx
+export GTK_IM_MODULE=$im
+export QT_IM_MODULE=$im
+export XMODIFIERS=@im=$im
+export INPUT_METHOD=$im
+export SDL_IM_MODULE=$im
diff --git a/enable-fcitx5.sh b/enable-fcitx5.sh
deleted file mode 100644
index 514828e38994..000000000000
--- a/enable-fcitx5.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-# https://wiki.archlinux.org/index.php/Fcitx5
-export SDL_IM_MODULE=fcitx
-export GTK_IM_MODULE=fcitx
-export QT_IM_MODULE=fcitx5
-export XMODIFIERS=@im=fcitx
diff --git a/enable-ibus.sh b/enable-ibus.sh
index f216a6093895..cf2cd0039fa3 100644
--- a/enable-ibus.sh
+++ b/enable-ibus.sh
@@ -1,5 +1,7 @@
# https://wiki.archlinux.org/index.php/IBus
-#im=ibus
-export GTK_IM_MODULE=ibus
-export QT_IM_MODULE=ibus
-export XMODIFIERS=@im=ibus
+im=ibus
+export GTK_IM_MODULE=$im
+export QT_IM_MODULE=$im
+export XMODIFIERS=@im=$im
+export INPUT_METHOD=$im
+export SDL_IM_MODULE=$im