summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamLukeYes2020-06-30 17:37:35 +0800
committerSamLukeYes2020-06-30 17:37:35 +0800
commit7edbd10d7b96c1add4bbcac1682a58d8e1c1d930 (patch)
treee4a5fba3d424ffefc1b22ffeb8750929e39f2863
downloadaur-7edbd10d7b96c1add4bbcac1682a58d8e1c1d930.tar.gz
create pkgbase
-rw-r--r--.SRCINFO43
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD53
-rw-r--r--enable-fcitx.sh5
-rw-r--r--enable-ibus.sh5
-rw-r--r--ibus.desktop5
6 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf19fae07ea8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = manjaro-asian-input-support
+ pkgdesc = A fork of Manjaro Asian input support.
+ pkgver = 2020.06
+ pkgrel = 1
+ url = https://gitlab.manjaro.org/packages/community/manjaro-asian-input-support
+ arch = any
+ license = GPL
+ conflicts = manjaro-asian-input-support-gtk
+ conflicts = manjaro-asian-input-support-qt
+ conflicts = manjaro-asian-input-support-ibus
+ conflicts = manjaro-asian-input-support-fcitx
+ source = enable-ibus.sh
+ source = enable-fcitx.sh
+ source = ibus.desktop
+ md5sums = b974be25b7f91c392009cb8d9f1bd5b4
+ md5sums = fdbfae1bba8012daf984a76d7004ae3e
+ md5sums = f1a9f3406f8268383149889f4816cd52
+
+pkgname = ibus-input-support
+ pkgdesc = A fork of Manjaro Asian input support for ibus, with dependencies set to optional.
+ optdepends = ibus-libpinyin: a Chinese IME
+ optdepends = ibus-anthy: a Japanese IME
+ optdepends = ibus-hangul: a Korean IME
+ optdepends = ibus-unikey: a Vietnamese IME
+ optdepends = ibus-m17n: other languages provided by M17n (http://www.nongnu.org/m17n/)
+ provides = manjaro-asian-input-support-ibus
+
+pkgname = fcitx-input-support
+ pkgdesc = A fork of Manjaro Asian input support for fcitx, with dependencies set to optional.
+ optdepends = fcitx-qt5: QT input module
+ optdepends = fcitx-gtk3: GTK input module
+ optdepends = fcitx-configtool: GUI configuration tool
+ optdepends = fcitx-qt4: required by some closed source Chinese IMEs
+ optdepends = fcitx-googlepinyin: a Chinese IME
+ optdepends = fcitx-cloudpinyin: Internet resources to provide candidate input for Chinese
+ optdepends = fcitx-mozc: a Japanese IME
+ optdepends = fcitx-hangul: a Korean IME
+ optdepends = fcitx-unikey: a Vietnamese IME
+ optdepends = fcitx-sayura: a Sinhalese IME
+ optdepends = fcitx-m17n: other languages provided by M17n (http://www.nongnu.org/m17n/)
+ optdepends = kcm-fcitx: KDE configuration module
+ provides = manjaro-asian-input-support-fcitx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1749e8b7d082
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+src/
+pkg/
+*.deb \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20764cc791a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Sam L. Yes <manjaroyes123@outlook.com>
+# Upstream Maintainer: Stefano Capitani <stefanoatmanjarodororg>
+# Upstream Contributors: star2000 <i@star2000.work>
+
+pkgbase=manjaro-asian-input-support
+pkgname=('ibus-input-support' 'fcitx-input-support')
+pkgver=2020.06
+pkgrel=1
+pkgdesc="A fork of Manjaro Asian input support."
+arch=('any')
+url="https://gitlab.manjaro.org/packages/community/manjaro-asian-input-support"
+license=('GPL')
+source=('enable-ibus.sh' 'enable-fcitx.sh' 'ibus.desktop')
+md5sums=('b974be25b7f91c392009cb8d9f1bd5b4'
+ 'fdbfae1bba8012daf984a76d7004ae3e'
+ 'f1a9f3406f8268383149889f4816cd52')
+conflicts=("${pkgbase}-gtk" "${pkgbase}-qt" "${pkgbase}-ibus" "${pkgbase}-fcitx")
+
+package_ibus-input-support() {
+ pkgdesc='A fork of Manjaro Asian input support for ibus, with dependencies set to optional.'
+ #depends=('ibus')
+ optdepends=(
+ 'ibus-libpinyin: a Chinese IME'
+ 'ibus-anthy: a Japanese IME'
+ 'ibus-hangul: a Korean IME'
+ 'ibus-unikey: a Vietnamese IME'
+ 'ibus-m17n: other languages provided by M17n (http://www.nongnu.org/m17n/)'
+ )
+ provides=("${pkgbase}-ibus")
+
+ install -Dm644 "$srcdir/enable-ibus.sh" "$pkgdir/etc/profile.d/input-support.sh"
+ install -Dm644 "$srcdir/ibus.desktop" "$pkgdir/etc/xdg/autostart/ibus.desktop"
+}
+
+package_fcitx-input-support() {
+ pkgdesc='A fork of Manjaro Asian input support for fcitx, with dependencies set to optional.'
+ optdepends=(
+ 'fcitx-qt5: QT input module'
+ 'fcitx-gtk3: GTK input module'
+ 'fcitx-configtool: GUI configuration tool'
+ 'fcitx-qt4: required by some closed source Chinese IMEs'
+ 'fcitx-googlepinyin: a Chinese IME'
+ 'fcitx-cloudpinyin: Internet resources to provide candidate input for Chinese'
+ 'fcitx-mozc: a Japanese IME'
+ 'fcitx-hangul: a Korean IME'
+ 'fcitx-unikey: a Vietnamese IME'
+ 'fcitx-sayura: a Sinhalese IME'
+ 'fcitx-m17n: other languages provided by M17n (http://www.nongnu.org/m17n/)'
+ 'kcm-fcitx: KDE configuration module')
+ provides=("${pkgbase}-fcitx")
+
+ install -Dm644 "$srcdir/enable-fcitx.sh" "$pkgdir/etc/profile.d/input-support.sh"
+}
diff --git a/enable-fcitx.sh b/enable-fcitx.sh
new file mode 100644
index 000000000000..9485f98c23d5
--- /dev/null
+++ b/enable-fcitx.sh
@@ -0,0 +1,5 @@
+# https://wiki.archlinux.org/index.php/Fcitx
+im=fcitx
+export GTK_IM_MODULE=$im
+export QT_IM_MODULE=$im
+export XMODIFIERS=@im=$im
diff --git a/enable-ibus.sh b/enable-ibus.sh
new file mode 100644
index 000000000000..b9376d5e290f
--- /dev/null
+++ b/enable-ibus.sh
@@ -0,0 +1,5 @@
+# https://wiki.archlinux.org/index.php/IBus
+im=ibus
+export GTK_IM_MODULE=$im
+export QT_IM_MODULE=$im
+export XMODIFIERS=@im=$im
diff --git a/ibus.desktop b/ibus.desktop
new file mode 100644
index 000000000000..0cb8953e5067
--- /dev/null
+++ b/ibus.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=IBus
+Type=Application
+Exec=ibus-daemon -drx
+Terminal=false