summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorartemtech2017-08-16 18:29:08 +0700
committerartemtech2017-08-16 18:29:08 +0700
commit9a8a00eff0158f2beba282367d600462105381e9 (patch)
treec51845b5887161bc534b282c375c694137b47080
parente685c490964080ff4c9711c9d251287fc120cf54 (diff)
downloadaur-9a8a00eff0158f2beba282367d600462105381e9.tar.gz
fixed source, new optdepends, and add special credits
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 33 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6770fdf5eaa8..eb07a0e7356b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = manokwari
- pkgdesc = HTML5 desktop shell for GNOME 3 from BlankOn Projects
+ pkgdesc = HTML5 desktop shell from BlankOn Projects
pkgver = 1.0.13
- pkgrel = 2
+ pkgrel = 3
url = https://manokwari.blankonlinux.or.id
+ arch = i686
arch = x86_64
- arch = i386
license = GPL3
- makedepends = make
+ makedepends = gnome-common
makedepends = git
makedepends = vala
- depends = gnome-common
depends = mutter
depends = libunique3
depends = gnome-session
@@ -23,7 +22,10 @@ pkgbase = manokwari
optdepends = bromo-gtk-theme: Gtk theme optimized for Manokwari shell
optdepends = tebu-icon-theme: Official icon sets from BlankOn
optdepends = tebu-flat-icon-theme: flat version of tebu-icon from BlankOn
- source = manokwari::git+https://github.com/BlankOn/manokwari.git
+ optdepends = gnome-screensaver: Lockscreen support
+ optdepends = gnome-control-center: System settings
+ optdepends = gnome-terminal: Run commands via dashboard
+ source = https://github.com/BlankOn/manokwari/archive/1.0.13.tar.gz
md5sums = SKIP
pkgname = manokwari
diff --git a/PKGBUILD b/PKGBUILD
index a289f9ca8a9d..ea83512887ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
# Maintainer: artemtech <sofyanartem@gmail.com>
+# Credit: twa022 <twa022@gmail.com>
+
pkgname=manokwari
pkgver=1.0.13
-pkgrel=2
-pkgdesc="HTML5 desktop shell for GNOME 3 from BlankOn Projects"
-arch=('x86_64' 'i386')
+pkgrel=3
+pkgdesc="HTML5 desktop shell from BlankOn Projects"
+arch=('i686' 'x86_64')
url="https://manokwari.blankonlinux.or.id"
license=('GPL3')
-depends=('gnome-common' 'mutter' 'libunique3' 'gnome-session' 'glib2' 'gtk3' 'libwnck3' 'libgee' 'webkitgtk' 'gnome-menus' 'libnotify')
-makedepends=('make' 'git' 'vala')
+depends=('mutter' 'libunique3' 'gnome-session' 'glib2' 'gtk3' 'libwnck3' 'libgee' 'webkitgtk' 'gnome-menus' 'libnotify')
+makedepends=('gnome-common' 'git' 'vala')
optdepends=('bromo-gtk-theme: Gtk theme optimized for Manokwari shell'
-'tebu-icon-theme: Official icon sets from BlankOn'
-'tebu-flat-icon-theme: flat version of tebu-icon from BlankOn')
-source=("$pkgname"::"git+https://github.com/BlankOn/manokwari.git")
+ 'tebu-icon-theme: Official icon sets from BlankOn'
+ 'tebu-flat-icon-theme: flat version of tebu-icon from BlankOn'
+ 'gnome-screensaver: Lockscreen support'
+ 'gnome-control-center: System settings'
+ 'gnome-terminal: Run commands via dashboard')
+source=("https://github.com/BlankOn/$pkgname/archive/$pkgver.tar.gz")
md5sums=('SKIP')
prepare(){
- cd ${srcdir}/${pkgname}
- sed -i 's/gee-1.0/gee-0.8/g' configure.ac
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # Use gee-0.8 rather than gee-0.6
+ sed -i 's/gee-1.0/gee-0.8/g' configure.ac
+ # Fix documentations install dir
+ sed -i 's:\(manokwaridocdir =\).*:\1 ${prefix}/share/doc/manokwari:' Makefile.am
}
build(){
- cd ${srcdir}/${pkgname}
- ./autogen.sh
- make
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./autogen.sh
+ make
}
package() {
- cd ${srcdir}/${pkgname}
- make DESTDIR="$pkgdir/" install
- cp -R system/{css/,fonts/,img/,js/,widget/,texture.jpg,texture.xcf} --target-directory=$pkgdir/usr/lib/manokwari/system/
- chmod +x $pkgdir/usr/bin/blankon-session
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+ cp -R system/{css/,fonts/,img/,js/,widget/,texture.jpg,texture.xcf} --target-directory=$pkgdir/usr/lib/manokwari/system/
+ chmod +x $pkgdir/usr/bin/blankon-session
}