summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorartemtech2018-02-18 21:16:48 +0700
committerartemtech2018-02-18 21:16:48 +0700
commitcede37eadbc2c973478eccac938bf9eb86e0706b (patch)
tree9cd696bff4fab0a857b4f11a5d8db8686a329928
parent9a8a00eff0158f2beba282367d600462105381e9 (diff)
downloadaur-cede37eadbc2c973478eccac938bf9eb86e0706b.tar.gz
add missing lib and new rules for script
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea83512887ed..83e17ba360d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Credit: twa022 <twa022@gmail.com>
pkgname=manokwari
-pkgver=1.0.13
-pkgrel=3
+pkgver=1.0.18
+pkgrel=1
pkgdesc="HTML5 desktop shell from BlankOn Projects"
arch=('i686' 'x86_64')
url="https://manokwari.blankonlinux.or.id"
license=('GPL3')
depends=('mutter' 'libunique3' 'gnome-session' 'glib2' 'gtk3' 'libwnck3' 'libgee' 'webkitgtk' 'gnome-menus' 'libnotify')
-makedepends=('gnome-common' 'git' 'vala')
+makedepends=('gnome-common' 'git' 'vala' 'icu59' 'enchant1.6' 'cairo-ubuntu')
optdepends=('bromo-gtk-theme: Gtk theme optimized for Manokwari shell'
'tebu-icon-theme: Official icon sets from BlankOn'
'tebu-flat-icon-theme: flat version of tebu-icon from BlankOn'
@@ -25,6 +25,12 @@ prepare(){
sed -i 's/gee-1.0/gee-0.8/g' configure.ac
# Fix documentations install dir
sed -i 's:\(manokwaridocdir =\).*:\1 ${prefix}/share/doc/manokwari:' Makefile.am
+ # Patching blankon-session install
+ cat << @@@ > files/bin/Makefile.am
+sessiondir = $(bindir)
+dist_bin_SCRIPTS = blankon-session
+CLEANFILES = $(dist_bin_SCRIPTS)
+@@@
}
build(){
@@ -36,6 +42,4 @@ build(){
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="$pkgdir/" install
- cp -R system/{css/,fonts/,img/,js/,widget/,texture.jpg,texture.xcf} --target-directory=$pkgdir/usr/lib/manokwari/system/
- chmod +x $pkgdir/usr/bin/blankon-session
}