summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Whitfield2017-08-07 13:24:42 -0400
committerRoss Whitfield2017-08-07 13:24:42 -0400
commit5637f8c0cf77c35e7600fba102ba19de1e2c957d (patch)
tree6187bc4fd1057463526eabb2df7db4843de29407
parent7bebaf3082c5001eae9541bd019fc6fc84dea3ae (diff)
downloadaur-5637f8c0cf77c35e7600fba102ba19de1e2c957d.tar.gz
Update depends
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD39
2 files changed, 50 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8662d4f56250..001000a863e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,42 @@
pkgbase = mantid
pkgdesc = Data analysis toolkit for neutron based instrument data
pkgver = 3.10.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.mantidproject.org/
arch = x86_64
arch = i686
license = GPL
+ makedepends = boost
makedepends = cmake
+ makedepends = python2-sphinx
+ makedepends = python2-sphinx-bootstrap-theme
+ depends = boost-libs
+ depends = glu
+ depends = gperftools
+ depends = gsl
+ depends = hdf4
+ depends = hdf5
+ depends = intel-tbb
+ depends = jsoncpp
depends = libnexus
- depends = qwt5
- depends = qwtplot3d
- depends = qscintilla
- depends = boost
- depends = poco
+ depends = libxslt
depends = muparser
- depends = qtwebkit
- depends = jsoncpp
- depends = ipython2
+ depends = opencascade
+ depends = poco
depends = python2
+ depends = python2-dateutil
+ depends = python2-h5py
depends = python2-numpy
depends = python2-pyqt4
depends = python2-pyzmq
+ depends = python2-qtconsole
depends = python2-scipy
depends = python2-sip
- depends = hdf5
- depends = gsl
+ depends = python2-yaml
+ depends = qscintilla
+ depends = qtwebkit
+ depends = qwt5
+ depends = qwtplot3d
source = mantid::git+https://github.com/mantidproject/mantid.git#tag=v3.10.1
source = https://github.com/mantidproject/mantid/pull/19889.patch
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4eb5f09ecfee..9c769121e78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,47 @@
pkgname=mantid
pkgver=3.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Data analysis toolkit for neutron based instrument data"
url="http://www.mantidproject.org/"
arch=('x86_64' 'i686')
license=('GPL')
depends=(
+ 'boost-libs'
+ 'glu'
+ 'gperftools'
+ 'gsl'
+ 'hdf4'
+ 'hdf5'
+ 'intel-tbb'
+ 'jsoncpp'
'libnexus'
- 'qwt5'
- 'qwtplot3d'
- 'qscintilla'
- 'boost'
- 'poco'
+ 'libxslt'
'muparser'
- 'qtwebkit'
- 'jsoncpp'
- 'ipython2'
+ 'opencascade'
+ 'poco'
'python2'
+ 'python2-dateutil'
+ 'python2-h5py'
'python2-numpy'
'python2-pyqt4'
'python2-pyzmq'
+ 'python2-qtconsole'
'python2-scipy'
'python2-sip'
- 'hdf5'
- 'gsl'
+ 'python2-yaml'
+ 'qscintilla'
+ 'qtwebkit'
+ 'qwt5'
+ 'qwtplot3d'
+ )
+
+makedepends=(
+ 'boost'
+ 'cmake'
+ 'python2-sphinx'
+ 'python2-sphinx-bootstrap-theme'
)
-makedepends=('cmake')
source=("$pkgname::git+https://github.com/mantidproject/mantid.git#tag=v${pkgver}"
"https://github.com/mantidproject/mantid/pull/19889.patch")
sha1sums=('SKIP'